summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-03-04 14:51:43 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-07 08:45:22 +0700
commitee37a124db82a44b7c423f630d04a81ca33ec6c8 (patch)
tree325ea4a4952181bdd29f4858df91907432598fce /libraries
parentc20a9b15929171fd0c30a609537c4e2a6cd98663 (diff)
downloadslackbuilds-ee37a124db82a44b7c423f630d04a81ca33ec6c8.tar.gz
slackbuilds-ee37a124db82a44b7c423f630d04a81ca33ec6c8.tar.xz
libraries/PyOpenGL: Updated for version 3.1.6, add python3 support.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/PyOpenGL/PyOpenGL.SlackBuild19
-rw-r--r--libraries/PyOpenGL/PyOpenGL.info8
2 files changed, 14 insertions, 13 deletions
diff --git a/libraries/PyOpenGL/PyOpenGL.SlackBuild b/libraries/PyOpenGL/PyOpenGL.SlackBuild
index 8d7711cf00..9bcec6a582 100644
--- a/libraries/PyOpenGL/PyOpenGL.SlackBuild
+++ b/libraries/PyOpenGL/PyOpenGL.SlackBuild
@@ -3,25 +3,25 @@
# Slackware build script for PyOpenGL
# Written by Evandro Alves Rodrigues
+# 20220304 bkw: Modified by SlackBuilds.org: update for v3.1.6,
+# add python3 support.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=PyOpenGL
-VERSION=${VERSION:-3.0.1}
+VERSION=${VERSION:-3.1.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -48,18 +48,19 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- ChangeLog.txt PKG-INFO license.txt \
+ readme.rst PKG-INFO license.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/PyOpenGL/PyOpenGL.info b/libraries/PyOpenGL/PyOpenGL.info
index 4cb7c8dcac..fca23490a0 100644
--- a/libraries/PyOpenGL/PyOpenGL.info
+++ b/libraries/PyOpenGL/PyOpenGL.info
@@ -1,8 +1,8 @@
PRGNAM="PyOpenGL"
-VERSION="3.0.1"
-HOMEPAGE="http://pyopengl.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/pyopengl/PyOpenGL-3.0.1.tar.gz"
-MD5SUM="221d4a6a0928fcfeef26751370ec5f52"
+VERSION="3.1.6"
+HOMEPAGE="https://pypi.org/project/PyOpenGL/"
+DOWNLOAD="https://files.pythonhosted.org/packages/5b/01/f8fd986bc7f456f1a925ee0239f0391838ade92cdb6e5b674ffb8b86cfd6/PyOpenGL-3.1.6.tar.gz"
+MD5SUM="b6c4ca4c3321be7a1ace35c7b4db1751"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""