summaryrefslogtreecommitdiffstats
path: root/misc/zyGrib/zyGrib.SlackBuild
diff options
context:
space:
mode:
author Chris Abela <kristofru@gmail.com>2011-12-11 14:09:18 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-11 14:09:18 -0200
commit733e5ec566dad13b5219890c82d94b87e3288575 (patch)
tree661d27e30765e84e840cb059c11df14db41ba79c /misc/zyGrib/zyGrib.SlackBuild
parent38ed2ee04c3447e2b55119cbba56b306c5ab7788 (diff)
downloadslackbuilds-733e5ec566dad13b5219890c82d94b87e3288575.tar.gz
slackbuilds-733e5ec566dad13b5219890c82d94b87e3288575.tar.xz
misc/zyGrib: Added (Visualization of meteo data)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'misc/zyGrib/zyGrib.SlackBuild')
-rw-r--r--misc/zyGrib/zyGrib.SlackBuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/misc/zyGrib/zyGrib.SlackBuild b/misc/zyGrib/zyGrib.SlackBuild
new file mode 100644
index 0000000000..aeb1861811
--- /dev/null
+++ b/misc/zyGrib/zyGrib.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for appname
+
+# Copyright 2011 Chris Abela, Malta
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=zyGrib
+VERSION=${VERSION:-5.0.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# zyGrib lacks configure scripts so the options are limited
+
+set -e
+
+# In case the source was fetched with wget or some other downloader:
+SRCTAR=$PRGNAM-$VERSION.tgz
+[ -e "getfile.php?file=$SRCTAR" ] && SRCTAR="getfile.php?file=$SRCTAR"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/opt/$PRGNAM $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCTAR
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# src/zyGrib.pro is looking for the wrong qwt library
+sed -i 's/lqwt-qt4/lqwt/' src/zyGrib.pro
+
+# Makefile installs a good local installation, but we need a system installation
+patch -p0 < $CWD/Makefile.patch
+
+# See http://www.zygrib.org/forum/viewtopic.php?f=3&t=221&view=print
+[ "$ARCH" = x86_64 ] && make veryclean
+make
+make install INSTALLDIR=$PKG/opt/$PRGNAM
+
+mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
+cat $CWD/zyGrib.desktop > $PKG/usr/share/applications/zyGrib.desktop
+cat $CWD/zyGrib.png > $PKG/usr/share/pixmaps/zyGrib.png
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}