summaryrefslogtreecommitdiffstats
path: root/multimedia/kaffeine
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-05 19:26:57 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-17 09:40:16 +0700
commit4710ee3fa730dcc37d1c6430741e0db2c59e3296 (patch)
tree149748bee5dc5703d922cfa22652ca289ae453bc /multimedia/kaffeine
parentc58bc4ec30c7aab3553a14eef50cd18e59f753d3 (diff)
downloadslackbuilds-4710ee3fa730dcc37d1c6430741e0db2c59e3296.tar.gz
slackbuilds-4710ee3fa730dcc37d1c6430741e0db2c59e3296.tar.xz
multimedia/kaffeine: Updated for version 1.3.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia/kaffeine')
-rw-r--r--multimedia/kaffeine/CMakeLists.patch24
-rw-r--r--multimedia/kaffeine/README6
-rw-r--r--multimedia/kaffeine/kaffeine-fix-gcc4.7.patch35
-rw-r--r--multimedia/kaffeine/kaffeine.SlackBuild17
-rw-r--r--multimedia/kaffeine/kaffeine.info8
-rw-r--r--multimedia/kaffeine/slack-desc6
6 files changed, 42 insertions, 54 deletions
diff --git a/multimedia/kaffeine/CMakeLists.patch b/multimedia/kaffeine/CMakeLists.patch
new file mode 100644
index 0000000000..d70973660e
--- /dev/null
+++ b/multimedia/kaffeine/CMakeLists.patch
@@ -0,0 +1,24 @@
+From 4a1a90ee1b2b4d13302046f043adf1c2a1de758d Mon Sep 17 00:00:00 2001
+From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Thu, 26 Nov 2015 15:36:26 +0100
+Subject: [PATCH] Explicitly include CheckIncludeFiles.
+
+This fixes the build with CMake 3.4.0. We were calling check_include_files()
+and implicitly relying on CheckIncludeFiles being included.
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d9be8db..b74b44d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,6 +21,7 @@ if(STRICT_BUILD)
+ -DQT_NO_URL_CAST_FROM_STRING -DQT_STRICT_ITERATORS)
+ endif(STRICT_BUILD)
+
++include(CheckIncludeFiles)
+ check_include_files(${CMAKE_CURRENT_SOURCE_DIR}/include/frontend.h HAVE_DVB)
+
+ if(NOT HAVE_DVB)
+
diff --git a/multimedia/kaffeine/README b/multimedia/kaffeine/README
index d2f9036e2c..8779f8987e 100644
--- a/multimedia/kaffeine/README
+++ b/multimedia/kaffeine/README
@@ -1,3 +1,3 @@
-Kaffeine is a full featured Multimedia-Player for KDE. By default, it uses
-xine as backend. Kaffeine is free software distributed under the terms of
-the GNU General Public Licence.
+Kaffeine is a full featured Multimedia-Player for KDE.
+Kaffeine is free software distributed under the terms of the
+GNU General Public Licence.
diff --git a/multimedia/kaffeine/kaffeine-fix-gcc4.7.patch b/multimedia/kaffeine/kaffeine-fix-gcc4.7.patch
deleted file mode 100644
index 7d8785aa6b..0000000000
--- a/multimedia/kaffeine/kaffeine-fix-gcc4.7.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Christoph Pfister <christophpfister@gmail.com>
-Date: Wed, 04 Apr 2012 19:22:09 +0000
-Subject: fix build for gcc 4.7
-X-Git-Url: http://quickgit.kde.org/?p=kaffeine.git&amp;a=commitdiff&amp;h=2da9df1e67004c3cfa879578c351300a99f23da1
----
-fix build for gcc 4.7
----
-
-
---- a/src/dvb/dvbepg.cpp
-+++ b/src/dvb/dvbepg.cpp
-@@ -690,15 +690,15 @@
- // 1980-01-06T000000 minus 15 secs (= UTC - GPS in 2011)
- QDateTime baseDateTime = QDateTime(QDate(1980, 1, 5), QTime(23, 59, 45), Qt::UTC);
-
-- for (AtscEitSectionEntry entry = eitSection.entries(); (entryCount > 0) && entry.isValid();
-- --entryCount, entry.advance()) {
-+ for (AtscEitSectionEntry eitEntry = eitSection.entries();
-+ (entryCount > 0) && eitEntry.isValid(); --entryCount, eitEntry.advance()) {
- DvbEpgEntry epgEntry;
- epgEntry.channel = channel;
-- epgEntry.begin = baseDateTime.addSecs(entry.startTime());
-- epgEntry.duration = QTime().addSecs(entry.duration());
-- epgEntry.title = entry.title();
--
-- quint32 id = ((quint32(fakeChannel.networkId) << 16) | quint32(entry.eventId()));
-+ epgEntry.begin = baseDateTime.addSecs(eitEntry.startTime());
-+ epgEntry.duration = QTime().addSecs(eitEntry.duration());
-+ epgEntry.title = eitEntry.title();
-+
-+ quint32 id = ((quint32(fakeChannel.networkId) << 16) | quint32(eitEntry.eventId()));
- DvbSharedEpgEntry entry = epgEntries.value(id);
-
- if (entry.isValid() && (entry->channel == epgEntry.channel) &&
-
diff --git a/multimedia/kaffeine/kaffeine.SlackBuild b/multimedia/kaffeine/kaffeine.SlackBuild
index b2705152b5..3bb4a2f908 100644
--- a/multimedia/kaffeine/kaffeine.SlackBuild
+++ b/multimedia/kaffeine/kaffeine.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=kaffeine
-VERSION=${VERSION:-1.2.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.3.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,13 +66,12 @@ tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
cd $PRGNAM-$SRC_VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Add upstream patch
-patch -p1 < $CWD/kaffeine-fix-gcc4.7.patch
+patch -p1 < $CWD/CMakeLists.patch
mkdir -p build
cd build
cmake \
@@ -87,7 +86,7 @@ cd build
make install VERBOSE=1 DESTDIR=$PKG
cd -
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/multimedia/kaffeine/kaffeine.info b/multimedia/kaffeine/kaffeine.info
index 62ec987b31..19dc2ca843 100644
--- a/multimedia/kaffeine/kaffeine.info
+++ b/multimedia/kaffeine/kaffeine.info
@@ -1,10 +1,10 @@
PRGNAM="kaffeine"
-VERSION="1.2.2"
+VERSION="1.3.1"
HOMEPAGE="http://kaffeine.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/kaffeine/kaffeine-1.2.2.tar.gz"
-MD5SUM="690e48d2e5fe123887109aa9b1bc1c31"
+DOWNLOAD="http://downloads.sourceforge.net/kaffeine/kaffeine-1.3.1.tar.gz"
+MD5SUM="f2308cf7abf5ec7ad5c724593594c198"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="vlc"
MAINTAINER="Michiel van Wessem"
EMAIL="michiel@slackbuilds.org"
diff --git a/multimedia/kaffeine/slack-desc b/multimedia/kaffeine/slack-desc
index 3de9f47e78..19a7544a35 100644
--- a/multimedia/kaffeine/slack-desc
+++ b/multimedia/kaffeine/slack-desc
@@ -8,9 +8,9 @@
|-----handy-ruler------------------------------------------------------|
kaffeine: Kaffeine (multimedia player for kde)
kaffeine:
-kaffeine: Kaffeine is a full featured Multimedia-Player for KDE. By default
-kaffeine: it uses xine as backend. Kaffeine is free software distributed under
-kaffeine: the terms of the GNU General Public Licence.
+kaffeine: Kaffeine is a full featured Multimedia-Player for KDE.
+kaffeine: Kaffeine is free software distributed under the terms of the
+kaffeine: GNU General Public Licence.
kaffeine:
kaffeine: Homepage: http://kaffeine.sourceforge.net
kaffeine: