summaryrefslogtreecommitdiffstats
path: root/multimedia/subtitlecomposer/link_gobject.patch
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@gmail.com>2012-09-17 21:51:03 +0700
committer Robby Workman <rworkman@slackbuilds.org>2012-09-17 23:36:13 -0500
commit6194d0b79e50e1f13932d2d0ccc836a191f6154b (patch)
tree4660b565a07b105cd87d1f163b8e6b85a105f2ee /multimedia/subtitlecomposer/link_gobject.patch
parentd59497fc9bf2965e2dc12315a3386c2844ed3f10 (diff)
downloadslackbuilds-6194d0b79e50e1f13932d2d0ccc836a191f6154b.tar.gz
slackbuilds-6194d0b79e50e1f13932d2d0ccc836a191f6154b.tar.xz
multimedia/subtitlecomposer: rebuilt to add patches to compile.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'multimedia/subtitlecomposer/link_gobject.patch')
-rw-r--r--multimedia/subtitlecomposer/link_gobject.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/multimedia/subtitlecomposer/link_gobject.patch b/multimedia/subtitlecomposer/link_gobject.patch
new file mode 100644
index 0000000000..93a69c479f
--- /dev/null
+++ b/multimedia/subtitlecomposer/link_gobject.patch
@@ -0,0 +1,15 @@
+# Description: This pacth adds a missing find_package for GObject.
+# Without this patch the package will FTBFS with binutils-gold.
+# Forwarded: http://sourceforge.net/tracker/?func=detail&aid=2897376&group_id=208427&atid=1005654
+# Author: José Manuel Santamaría Lema <panfaust@gmail.com>
+#
+--- subtitlecomposer-0.5.3.orig/src/player/gstreamer/CMakeLists.txt
++++ subtitlecomposer-0.5.3/src/player/gstreamer/CMakeLists.txt
+@@ -1,6 +1,7 @@
+ # TODO WHY AREN'T THESE INCLUDED BY MACRO_OPTIONAL_FIND_PACKAGE( GStreamer )?
+ FIND_PACKAGE( GLIB2 REQUIRED )
+ FIND_PACKAGE( LibXml2 REQUIRED )
++FIND_PACKAGE( GObject REQUIRED )
+
+ SET( players_gstreamer_INCLUDE_DIR
+ ${GLIB2_INCLUDE_DIR}