summaryrefslogtreecommitdiffstats
path: root/network/PySocks/PySocks.SlackBuild
diff options
context:
space:
mode:
author Fernando Lopez Jr <fernando.lopezjr@gmail.com>2018-01-05 13:57:35 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-01-06 06:41:49 +0700
commit4b98a167ab93e5fc40136846a19c726aa864f958 (patch)
tree15347b3c04d51a87e77d7ef346b83e36a5be88c0 /network/PySocks/PySocks.SlackBuild
parent3dff4a8780f4e35ab793f6a00cba2c40dbfca8e9 (diff)
downloadslackbuilds-4b98a167ab93e5fc40136846a19c726aa864f958.tar.gz
slackbuilds-4b98a167ab93e5fc40136846a19c726aa864f958.tar.xz
network/PySocks: Updated for version 1.6.8.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/PySocks/PySocks.SlackBuild')
-rw-r--r--network/PySocks/PySocks.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/network/PySocks/PySocks.SlackBuild b/network/PySocks/PySocks.SlackBuild
index 4d7b603995..0c37c92309 100644
--- a/network/PySocks/PySocks.SlackBuild
+++ b/network/PySocks/PySocks.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=PySocks
-VERSION=${VERSION:-1.5.7}
+VERSION=${VERSION:-1.6.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true