summaryrefslogtreecommitdiffstats
path: root/network/bottle
diff options
context:
space:
mode:
author Philip Lacroix <slackph at posteo dot de>2015-09-11 01:48:16 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-11 01:48:16 +0700
commit4e7c68052434879912d3eed66ac2e1c4db960df2 (patch)
tree9a4759d171e8acac202bf6cc7cd6501bede8fac3 /network/bottle
parentd0add4f89dfca5eed2c2c832b8fb314bd0fb49d6 (diff)
downloadslackbuilds-4e7c68052434879912d3eed66ac2e1c4db960df2.tar.gz
slackbuilds-4e7c68052434879912d3eed66ac2e1c4db960df2.tar.xz
network/bottle: Update EMAIL.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/bottle')
-rw-r--r--network/bottle/README2
-rw-r--r--network/bottle/bottle.SlackBuild13
-rw-r--r--network/bottle/bottle.info2
-rw-r--r--network/bottle/slack-desc4
4 files changed, 11 insertions, 10 deletions
diff --git a/network/bottle/README b/network/bottle/README
index 9506e8bf4e..f64ed2a768 100644
--- a/network/bottle/README
+++ b/network/bottle/README
@@ -1,4 +1,4 @@
-Bottle is a fast and simple micro-framework for small web applications. It
+bottle is a fast and simple micro-framework for small web applications. It
offers request dispatching (Routes) with url parameter support, templates,
a built-in HTTP Server and adapters for many third party WSGI/HTTP-server and
template engines - all in a single file and with no dependencies other than
diff --git a/network/bottle/bottle.SlackBuild b/network/bottle/bottle.SlackBuild
index 0597abd297..abe47cf5db 100644
--- a/network/bottle/bottle.SlackBuild
+++ b/network/bottle/bottle.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/sh
-# Slackware build script for Bottle
+# Slackware build script for bottle
-# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# Copyright 2015 Philip Lacroix <slackph at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -55,8 +55,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
python setup.py install --root=$PKG
# Python 3 support.
@@ -64,9 +62,12 @@ if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Install documentation.
mkdir -p $PRGDOC
cp -a README.rst PKG-INFO $PRGDOC/
cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
diff --git a/network/bottle/bottle.info b/network/bottle/bottle.info
index 0fd2be3a0d..a79bfc2b44 100644
--- a/network/bottle/bottle.info
+++ b/network/bottle/bottle.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="Philip Lacroix"
-EMAIL="philnx at posteo dot de"
+EMAIL="slackph at posteo dot de"
diff --git a/network/bottle/slack-desc b/network/bottle/slack-desc
index cca52162cb..b0c8f445a0 100644
--- a/network/bottle/slack-desc
+++ b/network/bottle/slack-desc
@@ -6,9 +6,9 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-bottle: Bottle (Python web framework)
+bottle: bottle (Python web framework)
bottle:
-bottle: Bottle is a fast, simple and lightweight WSGI micro web-framework
+bottle: bottle is a fast, simple and lightweight WSGI micro web-framework
bottle: for Python. It is distributed as a single file module and has no
bottle: dependencies other than the Python Standard Library.
bottle: