summaryrefslogtreecommitdiffstats
path: root/network/exim/exim.SlackBuild
diff options
context:
space:
mode:
author Thomas Morper <thomas@beingboiled.info>2015-07-28 23:11:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-07-28 23:12:03 +0700
commitc6f8078c1b8c92b345bec3617007205e56521496 (patch)
treed2c05c7e9f311555267286701fa05d1f822673c9 /network/exim/exim.SlackBuild
parent1c0a9d208699e93a07b6d203fe1d306f3263fff7 (diff)
downloadslackbuilds-c6f8078c1b8c92b345bec3617007205e56521496.tar.gz
slackbuilds-c6f8078c1b8c92b345bec3617007205e56521496.tar.xz
network/exim: Updated for version 4.86.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/exim/exim.SlackBuild')
-rw-r--r--network/exim/exim.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
index ded13e2889..6afeb8c932 100644
--- a/network/exim/exim.SlackBuild
+++ b/network/exim/exim.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Exim
-# Copyright 2012-2014 Thomas Morper, Augsburg, Germany
+# Copyright 2012-2015 Thomas Morper, Augsburg, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=exim
-VERSION=${VERSION:-4.85}
+VERSION=${VERSION:-4.86}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,6 +49,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -91,9 +94,8 @@ cat exim_monitor/EDITME > Local/eximon.conf
# Use the Exim build system to set the architecture-specific CFLAGS.
# This requires "make" to run twice, in case you wonder. If you want
# to use your own CFLAGS in exim.Makefile, you should put a '#' in
-# front of the next 4 lines.
-echo "CFLAGS=$SLKCFLAGS" > Local/Makefile-Linux
-echo "CFLAGS+=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" > Local/Makefile-Linux-i386
+# front of the next 3 lines.
+echo "CFLAGS=$SLKCFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" > Local/Makefile-Linux
FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e || true
FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e makefile