summaryrefslogtreecommitdiffstats
path: root/network/flexget/flexget.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-08-12 16:46:03 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-08-13 07:22:40 +0700
commit0245a3f7f00ae29c9f3684df4a53ab13b0bf8981 (patch)
treec8560bf726f608d489339c12f115953fe4dc7853 /network/flexget/flexget.SlackBuild
parent1a290a1051949f0639b53646c23cbbac55034735 (diff)
downloadslackbuilds-0245a3f7f00ae29c9f3684df4a53ab13b0bf8981.tar.gz
slackbuilds-0245a3f7f00ae29c9f3684df4a53ab13b0bf8981.tar.xz
network/flexget: Updated for version 2.2.16.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'network/flexget/flexget.SlackBuild')
-rw-r--r--network/flexget/flexget.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/network/flexget/flexget.SlackBuild b/network/flexget/flexget.SlackBuild
index 4d7ad25158..fe6463a10e 100644
--- a/network/flexget/flexget.SlackBuild
+++ b/network/flexget/flexget.SlackBuild
@@ -28,7 +28,7 @@
SRCNAM=FlexGet
PRGNAM=${SRCNAM,,}
-VERSION=${VERSION:-1.2.358}
+VERSION=${VERSION:-2.2.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,7 +39,7 @@ OUTPUT=${OUTPUT:-/tmp}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
*) export ARCH=$( uname -m ) ;;
esac
@@ -58,7 +58,10 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix requirement 'flask-restplus' working with newer version
+sed -i "s/restplus=/restplus>/" requirements.txt
python setup.py install --root=$PKG