summaryrefslogtreecommitdiffstats
path: root/network/flexget/flexget.SlackBuild
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2022-06-04 04:51:56 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-06-11 08:58:59 +0700
commite98de23eb9a6d3516c8481a0855abd5686681f72 (patch)
tree90deee95475b6b3051f7625bf71e8d08add25d0b /network/flexget/flexget.SlackBuild
parent97997221811cda3a88216317f5e5c7c3fac1b0ab (diff)
downloadslackbuilds-e98de23eb9a6d3516c8481a0855abd5686681f72.tar.gz
slackbuilds-e98de23eb9a6d3516c8481a0855abd5686681f72.tar.xz
network/flexget: Updated for version 3.3.14.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/flexget/flexget.SlackBuild')
-rw-r--r--network/flexget/flexget.SlackBuild35
1 files changed, 26 insertions, 9 deletions
diff --git a/network/flexget/flexget.SlackBuild b/network/flexget/flexget.SlackBuild
index 28b1d8da06..0ae5fc1484 100644
--- a/network/flexget/flexget.SlackBuild
+++ b/network/flexget/flexget.SlackBuild
@@ -5,6 +5,7 @@
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Written by Lionel Young <redtricycle@gmail.com>
#
# All rights reserved.
@@ -26,15 +27,25 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220515 46and2: Updated version, removed python2, New maintainer.
+# -still needs fixes before uploading
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=flexget
-VERSION=${VERSION:-2.11.9}
+SRCNAM=FlexGet
+VERSION=${VERSION:-3.3.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=FlexGet
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
@@ -48,12 +59,18 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -74,7 +91,7 @@ find -L . \
# Remove versions from requirements
sed -i "s/==.*//" requirements.txt
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION