summaryrefslogtreecommitdiffstats
path: root/network/kvirc
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-03-01 16:30:17 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-03 15:56:42 +0700
commit5118983013062f543e1fa4908a22b420c57a62d9 (patch)
treee60171825043e9044f6403038d16f1605c04e839 /network/kvirc
parentbf014701b6abe4a001bb290c6587790c1fbeeae2 (diff)
downloadslackbuilds-5118983013062f543e1fa4908a22b420c57a62d9.tar.gz
slackbuilds-5118983013062f543e1fa4908a22b420c57a62d9.tar.xz
network/kvirc: Fix 15.0 build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/kvirc')
-rw-r--r--network/kvirc/README19
-rw-r--r--network/kvirc/kvirc.SlackBuild18
2 files changed, 18 insertions, 19 deletions
diff --git a/network/kvirc/README b/network/kvirc/README
index 98976bcd7f..7c4a9d8534 100644
--- a/network/kvirc/README
+++ b/network/kvirc/README
@@ -1,9 +1,10 @@
-KVIrc is the K-Visual IRC Client. It's a free portable Internet Relay
-Chat client based on the excellent Qt GUI toolkit. KVIrc is being written
-by Szymon Stefanek and The KVIrc Development Team with the contribution
-of many IRC addicted developers around the world. It has a full GUI
-based configuration, floatable windows, built-in help browser, addons and
-themes support (configurable from GUI or scripting), transparency support,
-dran'n'drop toolbar editing, activity notifier as well as proxy support,
-SSL and IPv6 sockets support, a modular arch which loads modules only when
-necessary and a huge API for writing extensions
+KVIrc is the K-Visual IRC Client. It's a free portable Internet
+Relay Chat client based on the excellent Qt GUI toolkit. KVIrc is
+being written by Szymon Stefanek and The KVIrc Development Team with
+the contribution of many IRC addicted developers around the world.
+It has a full GUI based configuration, floatable windows, built-in
+help browser, addons and themes support (configurable from GUI
+or scripting), transparency support, dran'n'drop toolbar editing,
+activity notifier as well as proxy support, SSL and IPv6 sockets
+support, a modular arch which loads modules only when necessary and a
+huge API for writing extensions
diff --git a/network/kvirc/kvirc.SlackBuild b/network/kvirc/kvirc.SlackBuild
index c2a415eee1..75118ba885 100644
--- a/network/kvirc/kvirc.SlackBuild
+++ b/network/kvirc/kvirc.SlackBuild
@@ -23,6 +23,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220301 bkw: Modified by SlackBuilds.org: fix build on 15.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kvirc
@@ -40,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,13 +76,16 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# use our *FLAGS
sed -i "s|\"-O3|\"$SLKCFLAGS|" CMakeLists.txt
+# 20220301 bkw: older qt5 didn't need this, but Slackware 15.0's does:
+sed -i '1i#include <QPainterPath>' src/modules/iograph/libkviiograph.cpp
+
mkdir build
cd build
cmake \
@@ -97,14 +99,10 @@ cd build
-DWANT_STRIP=ON \
..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING README.md RELEASES doc/*LICENSE* $PKG/usr/doc/$PRGNAM-$VERSION