summaryrefslogtreecommitdiffstats
path: root/network/mumble
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-02 19:51:36 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-06 18:11:15 +0700
commit778c734a76ab60f89f978e6f7b38cc311ceab94d (patch)
tree74794b7522056fc61a33f9211460f0fbb5bad726 /network/mumble
parentbcd160a60661dcbdfe1a377e4e745350ee3af409 (diff)
downloadslackbuilds-778c734a76ab60f89f978e6f7b38cc311ceab94d.tar.gz
slackbuilds-778c734a76ab60f89f978e6f7b38cc311ceab94d.tar.xz
network/mumble: Fix build with new protobuf3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/mumble')
-rw-r--r--network/mumble/mumble.SlackBuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/network/mumble/mumble.SlackBuild b/network/mumble/mumble.SlackBuild
index 6797b201cb..d1fcdfe5d6 100644
--- a/network/mumble/mumble.SlackBuild
+++ b/network/mumble/mumble.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mumble
VERSION=${VERSION:-1.4.287}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -46,9 +46,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -121,6 +118,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -e "s|CMAKE_CXX_STANDARD 14|CMAKE_CXX_STANDARD 17|" -i CMakeLists.txt
mkdir -p build
cd build
@@ -136,6 +134,7 @@ cmake \
-Dbundled-speex=OFF \
-Dupdate=OFF \
-Dbundle-qt-translations=OFF \
+ -Dwarnings-as-errors=OFF \
-Dice=OFF \
-Dzeroconf=OFF \
$BUILD_CELT \