summaryrefslogtreecommitdiffstats
path: root/network/offlineimap/offlineimap.SlackBuild
diff options
context:
space:
mode:
author Nishant Limbachia <nishant@mnspace.net>2011-07-14 23:38:28 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-07-14 23:38:28 -0500
commit43241823528dd4e8b5b5aba5d5574569ba28bca2 (patch)
tree60b8fe09b898f7631f4d03c76cf180330cf19230 /network/offlineimap/offlineimap.SlackBuild
parent620bcf57a35a786f2265fa6f658e8c6943cfdd1d (diff)
downloadslackbuilds-43241823528dd4e8b5b5aba5d5574569ba28bca2.tar.gz
slackbuilds-43241823528dd4e8b5b5aba5d5574569ba28bca2.tar.xz
network/offlineimap: Updated for version 6.3.3.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/offlineimap/offlineimap.SlackBuild')
-rw-r--r--network/offlineimap/offlineimap.SlackBuild35
1 files changed, 13 insertions, 22 deletions
diff --git a/network/offlineimap/offlineimap.SlackBuild b/network/offlineimap/offlineimap.SlackBuild
index bd596d5fd6..dc49239ddc 100644
--- a/network/offlineimap/offlineimap.SlackBuild
+++ b/network/offlineimap/offlineimap.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/sh
# Slackware build script for OfflineIMAP
-# Home Page http://software.complete.org/software/projects/show/offlineimap
+# Home Page https://github.com/nicolas33/offlineimap
-# Copyright (c) 2008-2009, Nishant Limbachia, Hoffman Est, IL, USA (nishant@mnspace.net)
+# Copyright (c) 2008-2011, Nishant Limbachia, Hoffman Estates, IL, USA <nishant _AT_ mnspace _DOT_ net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,23 +24,20 @@
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=offlineimap
-VERSION=6.2.0
+SRCNAM="nicolas33-offlineimap-v6.3.3-0-g3b09695"
+PRGNAM="offlineimap"
+VERSION=${VERSION:-6.3.3}
BUILD=${BUILD:-1}
-TAG=${TAG=_SBo}
+TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
-SRCNAM="nicolas33-offlineimap-debian-6.2.0-0-g5d4fe0c.tar.gz"
-
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -51,9 +48,10 @@ set -e # Exit on most errors
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-tar xvf $CWD/$SRCNAM
-mv nicolas33-offlineimap-1a9381a $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM.tar.gz
+mv nicolas33-offlineimap-cf325d5 $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
+
chown -R root.root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -61,25 +59,18 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-### build and install
-python setup.py install --root=$PKG
-
-### patch makefile to fix document generation
-patch -p0 < $CWD/doc_generation_fix.patch
-
-### make and install docs
-make doc
mkdir -p $PKG/usr/{man/man1,doc/$PRGNAM-$VERSION} $PKG/etc
+python setup.py install --root=$PKG
+make doc man
-### install config file
install -m 0644 -D $PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
install -m 0644 $PRGNAM.1 $PKG/usr/man/man1
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
cp -a \
- COPYING COPYRIGHT UPGRADING FAQ.html manual.* $PRGNAM.conf* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+ COPYING COPYRIGHT readme.html $PRGNAM.conf* docs/*.html \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install