summaryrefslogtreecommitdiffstats
path: root/network/onionshare
diff options
context:
space:
mode:
author MDrights <psychi2009@gmail.com>2019-01-09 06:57:51 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-01-09 06:57:51 +0700
commit5f349843ff06202e260a5db01ed4152dce1731db (patch)
treee81fc36213d1b5ff4fa6b1f915e2ff32e959df1c /network/onionshare
parent415181d2b997b0051e100b07fded6938083fd0e5 (diff)
downloadslackbuilds-5f349843ff06202e260a5db01ed4152dce1731db.tar.gz
slackbuilds-5f349843ff06202e260a5db01ed4152dce1731db.tar.xz
network/onionshare: Added (anonymous file sharing).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/onionshare')
-rw-r--r--network/onionshare/README9
-rw-r--r--network/onionshare/onionshare.SlackBuild73
-rw-r--r--network/onionshare/onionshare.info10
-rw-r--r--network/onionshare/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/network/onionshare/README b/network/onionshare/README
new file mode 100644
index 0000000000..c6fbb9c999
--- /dev/null
+++ b/network/onionshare/README
@@ -0,0 +1,9 @@
+OnionShare lets you securely and anonymously send and receive files.
+It works by starting a web server, making it accessible as a Tor onion
+service, and generating an unguessable web address so others can download
+files from you, or upload files to you. It does not require setting up
+a separate server or using a third party file-sharing service.
+
+It also requires obfs4proxy (or others e.g. meek) if tor bridge is used.
+
+It has templates of torrc which can be found in /usr/share/onionshare/.
diff --git a/network/onionshare/onionshare.SlackBuild b/network/onionshare/onionshare.SlackBuild
new file mode 100644
index 0000000000..dd7e855497
--- /dev/null
+++ b/network/onionshare/onionshare.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for onionshare
+
+# Copyright 2019 MDrights <psychi2009@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=onionshare
+VERSION=${VERSION:-1.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="LICENSE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Python 3 is a must.
+# python setup.py install --prefix=/usr --root=$PKG
+python3 setup.py install --root=$PKG --optimize=1
+
+# Copy docs, etc.
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cp $TMP/$PRGNAM-$VERSION/$DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/onionshare/onionshare.info b/network/onionshare/onionshare.info
new file mode 100644
index 0000000000..38b7082efe
--- /dev/null
+++ b/network/onionshare/onionshare.info
@@ -0,0 +1,10 @@
+PRGNAM="onionshare"
+VERSION="1.3.1"
+HOMEPAGE="https://onionshare.org/"
+DOWNLOAD="https://github.com/micahflee/onionshare/archive/v1.3.1/onionshare-1.3.1.tar.gz"
+MD5SUM="af186de10031e4dfd757bc213bb36b26"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 tor Flask stem python3-pycrypto PySocks python3-PyQt5"
+MAINTAINER="MDrights"
+EMAIL="psychi2009@gmail.com"
diff --git a/network/onionshare/slack-desc b/network/onionshare/slack-desc
new file mode 100644
index 0000000000..f532d9b316
--- /dev/null
+++ b/network/onionshare/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+onionshare: onionshare (anonymous file sharing)
+onionshare:
+onionshare: Securely and anonymously share a file of any size via Tor network.
+onionshare:
+onionshare: Homepage: https://onionshare.org/
+onionshare:
+onionshare:
+onionshare:
+onionshare:
+onionshare:
+onionshare: