summaryrefslogtreecommitdiffstats
path: root/network/prosody/prosody.SlackBuild
diff options
context:
space:
mode:
author Andrew Tkalia <anddt@yandex.ru>2014-04-28 23:17:35 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-28 23:17:35 +0700
commit8c9261b2348253b0be4f1fb2c1e3c9141a45696b (patch)
treec5f4705e51f6ccdd6e84ff3b029136de814e5640 /network/prosody/prosody.SlackBuild
parent278c5b0fe14c8c508bb115c4cdea2feabbe2645b (diff)
downloadslackbuilds-8c9261b2348253b0be4f1fb2c1e3c9141a45696b.tar.gz
slackbuilds-8c9261b2348253b0be4f1fb2c1e3c9141a45696b.tar.xz
network/prosody: Updated for version 0.9.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/prosody/prosody.SlackBuild')
-rw-r--r--network/prosody/prosody.SlackBuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/network/prosody/prosody.SlackBuild b/network/prosody/prosody.SlackBuild
index e37515c8f2..fad92e6637 100644
--- a/network/prosody/prosody.SlackBuild
+++ b/network/prosody/prosody.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=prosody
-VERSION=${VERSION:-0.8.2}
+VERSION=${VERSION:-0.9.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,10 +62,8 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- #SLKCFLAGS="-O2 -fPIC"
- #LIBDIRSUFFIX="64"
- echo "Your arch is not supported yet. I am sorry"
- exit 1
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -82,10 +80,14 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix path on x86_64
+sed -i "s|/lib/|/lib${LIBDIRSUFFIX}/|" Makefile
+sed -i "s|/lib/|/lib${LIBDIRSUFFIX}/|" tools/migration/Makefile
./configure \
--ostype=linux \
@@ -117,9 +119,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS INSTALL COPYING DEPENDS README HACKERS TODO doc/*.* \
- tools/{ejabberd2prosody.lua,erlparse.lua,xep227toprosody.lua,ejabberdsql2prosody.lua} \
+cp -a AUTHORS INSTALL COPYING DEPENDS README HACKERS TODO doc/*.* tools/*.lua \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild