summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2015-09-26 07:32:44 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-26 07:32:44 +0700
commit50395b92cd016fe041cb14348404c301e61944e4 (patch)
treead13dd83b982cb9d3ac2f52166aabf351fbd18d4 /network
parent4eb0d1fc1c42ed4a58f02aac2ae3fa3110bf6b7f (diff)
downloadslackbuilds-50395b92cd016fe041cb14348404c301e61944e4.tar.gz
slackbuilds-50395b92cd016fe041cb14348404c301e61944e4.tar.xz
network/youtube-upload: Added (YouTube command-line upload utility).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/youtube-upload/README2
-rw-r--r--network/youtube-upload/slack-desc19
-rw-r--r--network/youtube-upload/youtube-upload.SlackBuild84
-rw-r--r--network/youtube-upload/youtube-upload.info10
4 files changed, 115 insertions, 0 deletions
diff --git a/network/youtube-upload/README b/network/youtube-upload/README
new file mode 100644
index 0000000000..fae729bbbe
--- /dev/null
+++ b/network/youtube-upload/README
@@ -0,0 +1,2 @@
+Youtube-upload is a command line Python script that uploads videos
+to Youtube using the YouTube APIv3. \ No newline at end of file
diff --git a/network/youtube-upload/slack-desc b/network/youtube-upload/slack-desc
new file mode 100644
index 0000000000..e17eeedb0d
--- /dev/null
+++ b/network/youtube-upload/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+youtube-upload: youtube-upload (YouTube command-line upload utility)
+youtube-upload:
+youtube-upload: Youtube-upload is a command line Python script that uploads videos
+youtube-upload: to Youtube using the YouTube APIv3.
+youtube-upload:
+youtube-upload: Homepage: https://github.com/tokland/youtube-upload/
+youtube-upload:
+youtube-upload:
+youtube-upload:
+youtube-upload:
+youtube-upload:
diff --git a/network/youtube-upload/youtube-upload.SlackBuild b/network/youtube-upload/youtube-upload.SlackBuild
new file mode 100644
index 0000000000..261103bfa8
--- /dev/null
+++ b/network/youtube-upload/youtube-upload.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for "youtube-upload".
+
+# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=youtube-upload
+VERSION=${VERSION:-0.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/youtube-upload/youtube-upload.info b/network/youtube-upload/youtube-upload.info
new file mode 100644
index 0000000000..7706a92636
--- /dev/null
+++ b/network/youtube-upload/youtube-upload.info
@@ -0,0 +1,10 @@
+PRGNAM="youtube-upload"
+VERSION="0.8.0"
+HOMEPAGE="https://github.com/tokland/youtube-upload/"
+DOWNLOAD="https://github.com/tokland/youtube-upload/archive/0.8.0.tar.gz"
+MD5SUM="71c7c31f340b3b3ae30ffbe8dd23b0c1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="progressbar google-api-python-client six"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"