summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Brenton Earl <brent@exitstatusone.com>2016-12-16 23:52:24 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-17 01:18:33 +0700
commit65348558ef37deedab5c8d16844390ed16185063 (patch)
tree12a8104d7d101373f4aaad9e44296cad998e8a8e /network
parent5e139710ca902336859da9b962e8285a912ce325 (diff)
downloadslackbuilds-65348558ef37deedab5c8d16844390ed16185063.tar.gz
slackbuilds-65348558ef37deedab5c8d16844390ed16185063.tar.xz
network/SocksiPy: Update script.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/SocksiPy/SocksiPy.SlackBuild27
1 files changed, 20 insertions, 7 deletions
diff --git a/network/SocksiPy/SocksiPy.SlackBuild b/network/SocksiPy/SocksiPy.SlackBuild
index 6d3dbdfc32..f561dfe90a 100644
--- a/network/SocksiPy/SocksiPy.SlackBuild
+++ b/network/SocksiPy/SocksiPy.SlackBuild
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,6 +40,20 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
set -e
rm -rf $PKG
@@ -49,20 +63,19 @@ rm -rf $PRGNAM-$VERSION
mkdir $PRGNAM-$VERSION
tar -xzvf $CWD/$PRGNAM.tar.gz -C $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
-
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Add setup.py
cat $CWD/setup.py > setup.py
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION