summaryrefslogtreecommitdiffstats
path: root/office/LibreOffice/LibreOffice.SlackBuild
diff options
context:
space:
mode:
author Christoph Willing <chris.willing@linux.com>2021-08-21 22:43:26 +1000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-08-21 20:54:09 +0700
commitcc9379660fce9561232051e4a699de2b7cd244a5 (patch)
tree9ba8dbf972370ca41549d32fe9e57c3cfaf860ba /office/LibreOffice/LibreOffice.SlackBuild
parent8356508ff56fc9ec9aeb2a4d6e048f5b18019da3 (diff)
downloadslackbuilds-cc9379660fce9561232051e4a699de2b7cd244a5.tar.gz
slackbuilds-cc9379660fce9561232051e4a699de2b7cd244a5.tar.xz
office/LibreOffice: Updated for version 7.2.0.4
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/LibreOffice/LibreOffice.SlackBuild')
-rw-r--r--office/LibreOffice/LibreOffice.SlackBuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/office/LibreOffice/LibreOffice.SlackBuild b/office/LibreOffice/LibreOffice.SlackBuild
index 92193f6e70..5abae1c170 100644
--- a/office/LibreOffice/LibreOffice.SlackBuild
+++ b/office/LibreOffice/LibreOffice.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=LibreOffice
SRCNAM=libreoffice
-VERSION=${VERSION:-7.1.5.2}
+VERSION=${VERSION:-7.2.0.4}
SHORT_VERSION=${VERSION%.*.*}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -79,10 +79,18 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
cd $SRCNAM-$VERSION
-if [ "$HAVE_SRCS_TARBALL" = "1" ]; then
+if [ -r $CWD/$SRCNAM-${VERSION}-srcs.tar.xz ]; then
tar xvf $CWD/$SRCNAM-${VERSION}-srcs.tar.xz
+ # For 7.2.0.4 these aren't found as previously so unpack them manually
+ cd $TMP
+ tar xf libreoffice-${VERSION}/external/tarballs/libreoffice-translations-${VERSION}.tar.xz
+ tar xf libreoffice-${VERSION}/external/tarballs/libreoffice-help-${VERSION}.tar.xz
+ cd $SRCNAM-$VERSION
+else
+ HAVE_SRCS_TARBALL=0
fi
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -165,8 +173,6 @@ if pkg-config --exists libvlc ; then vlc="--enable-vlc" ; else vlc="" ; fi
# Other options
if pkg-config --exists avahi-core ; then avahi="--enable-avahi" ; else avahi="" ; fi
-if pkg-config --exists python3 ; then Python3="--enable-python=system" ; else Python3="" ; fi
-if pkg-config --exists Qt5 ; then qt5="--enable-qt5" ; else qt5="" ; fi
if pkg-config --exists valgrind ; then valgrind="--with-valgrind" ; else valgrind="" ; fi
use_ccache="--disable-ccache" ; [ "${USE_CCACHE:-no}" != "no" ] && use_ccache=""
@@ -192,14 +198,16 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
--with-vendor="Just Another Slacker" \
--with-lang="$LOLANGS" \
--enable-release-build=yes \
+ --enable-qt5 \
+ --enable-python=system \
--enable-gio \
+ --disable-skia \
$extct2n \
$extnumbertext \
$extnlpsolver \
$extlanguagetool \
$extwikipub \
$avahi \
- $Python3 \
$vlc \
$use_ccache \
$use_java \
@@ -265,7 +273,6 @@ extnlpsolver="--enable-ext-nlpsolver"; [ "${EXTNLPSOLVER:-yes}" != "yes" ] &
$lpsolve \
$mythes \
$postgresql \
- $qt5 \
$valgrind \
$ucpp \
$odbc \
@@ -285,11 +292,9 @@ fi
patch -p0 < $CWD/no-check-if-root.diff
# GCC10 requirements (Tx alienBOB)
-sed -i external/libcdr/ExternalProject_libcdr.mk \
- -e '/configure /i \\t\t&& sed -i "s/TRUE/true/g" src/lib/libcdr_utils.cpp \\'
sed -i external/libebook/ExternalProject_libebook.mk \
-e '/configure /i \\t\t&& sed -i "s/TRUE/true/g" src/lib/EBOOKCharsetConverter.cpp \\'
-sed -i i18npool/source/calendar/calendar_gregorian.cxx -e 's/TRUE/true/'
+
export LDFLAGS="-lboost_system"
make build-nocheck