summaryrefslogtreecommitdiffstats
path: root/office/calcurse/calcurse.SlackBuild
diff options
context:
space:
mode:
author Michiel van Wessem <michiel@slackbuilds.org>2010-05-12 17:44:36 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 17:44:36 +0200
commitced6313e1e0fe2302f3e8d342f0c5c8e225bf39f (patch)
tree381b0c40052f0f2cc2fba9e69b86d2e7f7715e31 /office/calcurse/calcurse.SlackBuild
parenta89e171892f9310402588f89b299d79573ff30ba (diff)
downloadslackbuilds-ced6313e1e0fe2302f3e8d342f0c5c8e225bf39f.tar.gz
slackbuilds-ced6313e1e0fe2302f3e8d342f0c5c8e225bf39f.tar.xz
office/calcurse: Updated for version 2.5
Diffstat (limited to 'office/calcurse/calcurse.SlackBuild')
-rw-r--r--office/calcurse/calcurse.SlackBuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/office/calcurse/calcurse.SlackBuild b/office/calcurse/calcurse.SlackBuild
index 4202b56bce..549b28f043 100644
--- a/office/calcurse/calcurse.SlackBuild
+++ b/office/calcurse/calcurse.SlackBuild
@@ -1,8 +1,7 @@
#!/bin/sh
# Slackware build script for calcurse
-
-# Copyright 2007-2008 Michiel van Wessem, Manchester, United Kingdom
+# Copyright 2007-2009 Michiel van Wessem, Manchester, United Kingdom
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -25,7 +24,7 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=calcurse
-VERSION=${VERSION:-2.3}
+VERSION=${VERSION:-2.5}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -35,13 +34,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
set -e # Exit on most errors
@@ -58,16 +50,25 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# CFLAGS are ignored here...
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --build=$ARCH-slackware-linux
+ --build=$ARCH-slackware-linux \
+
+# Make sure we have the right compile flags set as calcurse seems to
+# blatantly ignore this: no matter what we do.
+if [ "$ARCH" = "i486" ]; then
+ sed -i 's#CFLAGS = -O2 -Wall -g#CFLAGS="-O2 -march=i486 -mtune=i686 -Wall -g"#g' $TMP/$PRGNAM-$VERSION/Makefile
+elif [ "$ARCH" = "i686" ]; then
+ sed -i 's#CFLAGS = -O2 -Wall -g#CFLAGS="-O2 -march=i686 -mtune=i686 -Wall -g"#g' $TMP/$PRGNAM-$VERSION/Makefile
+fi
-make CFLAGS="$SLKCFLAGS" # but not here... :-)
-make install DESTDIR=$PKG
+make
+make install-strip DESTDIR=$PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true