summaryrefslogtreecommitdiffstats
path: root/office/fbreader
diff options
context:
space:
mode:
author Audrius Kažukauskas <neobug@tornado.ktu.lt>2010-05-11 20:01:49 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:01:49 +0200
commit900ae97b15d76bed1e184c7c89d17f3a43e099da (patch)
tree48d818e8b110a96a47aa590be1f308cd2682adb9 /office/fbreader
parent85d681f7e6e7fcc342e466ccaaecb00d049da24e (diff)
downloadslackbuilds-900ae97b15d76bed1e184c7c89d17f3a43e099da.tar.gz
slackbuilds-900ae97b15d76bed1e184c7c89d17f3a43e099da.tar.xz
office/fbreader: Added to 12.0 repository
Diffstat (limited to 'office/fbreader')
-rw-r--r--office/fbreader/README18
-rw-r--r--office/fbreader/doinst.sh3
-rw-r--r--office/fbreader/fbreader.SlackBuild75
-rw-r--r--office/fbreader/fbreader.info8
-rw-r--r--office/fbreader/slack-desc19
5 files changed, 123 insertions, 0 deletions
diff --git a/office/fbreader/README b/office/fbreader/README
new file mode 100644
index 0000000000..bfc9a32bf0
--- /dev/null
+++ b/office/fbreader/README
@@ -0,0 +1,18 @@
+FBReader is e-book reader for Linux PDAs and desktop.
+
+- Supported formats are: fb2 e-book format (style attributes are not supported
+ yet); HTML format (tables are not supported); CHM format (tables are not
+ supported); plucker format (embedded images are supported, tables are not
+ supported); Palmdoc (aportis doc); zTxt (Weasel format); TCR (psion text)
+ format; RTF format (stylesheets and tables are not supported); OEB format
+ (css and tables are not supported); OpenReader format (css and tables are not
+ supported); Non-DRM'ed mobipocket format (tables are not supported); Plain
+ text format.
+- Direct reading from tar, zip, gzip and bzip2 archives.
+- Automatically generated contents table.
+- Embedded images support.
+- Footnotes/hyperlinks support.
+
+This builds the QT-based user interface by default; if you prefer to build
+the GTK interface instead, run the script as follows:
+ UI=gtk ./fbreader.SlackBuild
diff --git a/office/fbreader/doinst.sh b/office/fbreader/doinst.sh
new file mode 100644
index 0000000000..34be13eb65
--- /dev/null
+++ b/office/fbreader/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x usr/bin/update-desktop-database ]; then
+ usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
+fi
diff --git a/office/fbreader/fbreader.SlackBuild b/office/fbreader/fbreader.SlackBuild
new file mode 100644
index 0000000000..1d732a0be9
--- /dev/null
+++ b/office/fbreader/fbreader.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for fbreader
+# Written by Audrius Kažukauskas <neobug@tornado.ktu.lt>
+
+PRGNAM=fbreader
+VERSION=0.8.8d
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# If you want to build the gtk interface instead, then change this
+# value to 'gtk' or run the script like this:
+# UI=gtk ./fbreader.SlackBuild
+UI=${UI:-qt}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-sources-$VERSION.tgz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# We're building for desktop against Qt3
+# If you want to build against GTK+2, just change UI_TYPE to gtk
+cat > makefiles/target.mk << EOF
+TARGET_ARCH = desktop
+UI_TYPE = $UI
+TARGET_STATUS = release
+EOF
+
+# Add SLKCFLAGS
+sed -i "s|CFLAGS =|CFLAGS = $SLKCFLAGS|" makefiles/arch/desktop.mk
+
+# Fix all Qt3 related flags
+sed -i 's|moc-qt3|moc|' makefiles/arch/desktop.mk
+sed -i 's|-I /usr/include/qt3|$(shell pkg-config --cflags qt-mt)|' makefiles/arch/desktop.mk
+sed -i 's|-lqt-mt|$(shell pkg-config --libs qt-mt)|' makefiles/arch/desktop.mk
+
+make
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+# Fix .desktop file
+sed -i 's|^Name=E-book reader|Name=FBReader|' $PKG/usr/share/applications/FBReader.desktop
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.build fbreader/LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/office/fbreader/fbreader.info b/office/fbreader/fbreader.info
new file mode 100644
index 0000000000..fcd6fac9be
--- /dev/null
+++ b/office/fbreader/fbreader.info
@@ -0,0 +1,8 @@
+PRGNAM="fbreader"
+VERSION="0.8.8d"
+HOMEPAGE="http://www.fbreader.org/"
+DOWNLOAD="http://www.fbreader.org/fbreader-sources-0.8.8d.tgz"
+MD5SUM="37839e49a7696e615cf87c3eba59e1a5"
+MAINTAINER="Audrius Kazukauskas"
+EMAIL="neobug@tornado.ktu.lt"
+APPROVED="rworkman"
diff --git a/office/fbreader/slack-desc b/office/fbreader/slack-desc
new file mode 100644
index 0000000000..361364f5fe
--- /dev/null
+++ b/office/fbreader/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fbreader: FBReader (e-book reader)
+fbreader:
+fbreader: FBReader is an e-book reader for various platforms.
+fbreader: It was orignally written for Sharp Zaurus.
+fbreader:
+fbreader: http://www.fbreader.org/
+fbreader:
+fbreader:
+fbreader:
+fbreader:
+fbreader: