summaryrefslogtreecommitdiffstats
path: root/python/cocos2d/cocos2d.SlackBuild
diff options
context:
space:
mode:
author klaatu <klaatu@member.fsf.org>2022-03-09 17:29:06 +1300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 12:12:53 +0700
commit7dbdfe80bb49de197eb03964e47b6cf8c84a0078 (patch)
tree4fa86e17181d10d9b15141b3627bf4402d1cc39a /python/cocos2d/cocos2d.SlackBuild
parentd888ea45122a41b04a96c6da904ca592f694665c (diff)
downloadslackbuilds-7dbdfe80bb49de197eb03964e47b6cf8c84a0078.tar.gz
slackbuilds-7dbdfe80bb49de197eb03964e47b6cf8c84a0078.tar.xz
python/cocos2d: removed
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/cocos2d/cocos2d.SlackBuild')
-rw-r--r--python/cocos2d/cocos2d.SlackBuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/python/cocos2d/cocos2d.SlackBuild b/python/cocos2d/cocos2d.SlackBuild
deleted file mode 100644
index 10f028fb7f..0000000000
--- a/python/cocos2d/cocos2d.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/bash
-# Slackware build script for Cocos2d
-
-# Copyright 2019 Klaatu | Lawrence NZ | klaatu@member.fsf.org
-# GNU All-Permissive License
-# Copying and distribution of this file, with or without modification,
-# are permitted in any medium without royalty provided the copyright
-# notice and this notice are preserved. This file is offered as-is,
-# without any warranty.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=cocos2d
-SRCNAM=cocos
-VERSION=${VERSION:-0.6.7}
-SRCVER=release-$VERSION
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-PYTHON=${PYTHON:-python}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$SRCVER
-tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
-cd $SRCNAM-$SRCVER
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-$PYTHON setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS.txt CHANGELOG CONTRIBUTING.rst \
- INSTALL LICENS* MANIFEST.in NEWS.txt README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE