summaryrefslogtreecommitdiffstats
path: root/python/jaraco-packaging
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-15 21:52:03 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:38 +0700
commit1bb7b40fbcf2f9407a3bbd563b99072b0ee18c1e (patch)
tree1a8f0c5bd7423e939f1f3cfafe4e0cee6a1fda06 /python/jaraco-packaging
parent1e4eb744a65ca7ad45c0d1007c6f2f51c2865c30 (diff)
downloadslackbuilds-1bb7b40fbcf2f9407a3bbd563b99072b0ee18c1e.tar.gz
slackbuilds-1bb7b40fbcf2f9407a3bbd563b99072b0ee18c1e.tar.xz
python/jaraco-packaging: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/jaraco-packaging')
-rw-r--r--python/jaraco-packaging/jaraco-packaging.SlackBuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/python/jaraco-packaging/jaraco-packaging.SlackBuild b/python/jaraco-packaging/jaraco-packaging.SlackBuild
index 84e2b55bcd..8b2c107a6e 100644
--- a/python/jaraco-packaging/jaraco-packaging.SlackBuild
+++ b/python/jaraco-packaging/jaraco-packaging.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,12 +65,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION