summaryrefslogtreecommitdiffstats
path: root/python/netifaces/netifaces.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-05-26 08:29:49 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-05-28 23:45:33 +0700
commita936176d14e6999afefef344e425484984788f18 (patch)
treead8f8ca83fdc54e648c15d55829871a917abf12b /python/netifaces/netifaces.SlackBuild
parent35538e5091e2f06909e68c69ee5a99be32df5978 (diff)
downloadslackbuilds-a936176d14e6999afefef344e425484984788f18.tar.gz
slackbuilds-a936176d14e6999afefef344e425484984788f18.tar.xz
python/netifaces: Updated for version 0.10.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/netifaces/netifaces.SlackBuild')
-rw-r--r--python/netifaces/netifaces.SlackBuild28
1 files changed, 25 insertions, 3 deletions
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
index 6164899bd3..d2641cc9ac 100644
--- a/python/netifaces/netifaces.SlackBuild
+++ b/python/netifaces/netifaces.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for netifaces
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netifaces
-VERSION=${VERSION:-0.8}
+VERSION=${VERSION:-0.10.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,11 +57,15 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import setuptools' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install