summaryrefslogtreecommitdiffstats
path: root/python/pygame
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:20 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:27 +0700
commit31cebe6ee687395dca31d4e48fb32479c4c01314 (patch)
tree7a689cd42b5cc126201f19798cc79e2153dc5c68 /python/pygame
parentc99731af6e8551218c0d4f3b23206974e4f42a9f (diff)
downloadslackbuilds-31cebe6ee687395dca31d4e48fb32479c4c01314.tar.gz
slackbuilds-31cebe6ee687395dca31d4e48fb32479c4c01314.tar.xz
python/pygame: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pygame')
-rw-r--r--python/pygame/README9
-rw-r--r--python/pygame/pygame.SlackBuild7
2 files changed, 7 insertions, 9 deletions
diff --git a/python/pygame/README b/python/pygame/README
index a5a5eb6337..653401ddde 100644
--- a/python/pygame/README
+++ b/python/pygame/README
@@ -1,4 +1,5 @@
-Pygame is a set of Python modules designed for writing games. It is written
-on top of the excellent SDL library. This allows you to create fully
-featured games and multimedia programs in the python language. Pygame is
-highly portable and runs on nearly every platform and operating system.
+Pygame is a set of Python modules designed for writing games. It is
+written on top of the excellent SDL library. This allows you to create
+fully featured games and multimedia programs in the python language.
+Pygame is highly portable and runs on nearly every platform and
+operating system.
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
index 89cd4697eb..2ea02df31e 100644
--- a/python/pygame/pygame.SlackBuild
+++ b/python/pygame/pygame.SlackBuild
@@ -78,15 +78,12 @@ sed -i '/^if "install"/,$d' setup.py
# Fix warning message for missings dependencies
patch -p1 < $CWD/config_unix.patch
-python -u buildconfig/config.py
+python2 -u buildconfig/config.py
CFLAGS="$SLKCFLAGS" \
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
-# Pythonn 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
CFLAGS="$SLKCFLAGS" \
python3 setup.py install --root=$PKG
-fi
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true