summaryrefslogtreecommitdiffstats
path: root/python/python-Levenshtein
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-03 06:48:47 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:56 -0500
commite5286256a9fd41c98637113ff48617051fcaec3f (patch)
treefc3d23bd82c2c7ad6643a0d693c256af815f639f /python/python-Levenshtein
parent0dc52667fc998173e7ef13967759e25f344e7e87 (diff)
downloadslackbuilds-e5286256a9fd41c98637113ff48617051fcaec3f.tar.gz
slackbuilds-e5286256a9fd41c98637113ff48617051fcaec3f.tar.xz
python/python-Levenshtein: Renamed python2-Levenshtein.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python-Levenshtein')
-rw-r--r--python/python-Levenshtein/README9
-rw-r--r--python/python-Levenshtein/python-Levenshtein.SlackBuild68
-rw-r--r--python/python-Levenshtein/python-Levenshtein.info10
-rw-r--r--python/python-Levenshtein/slack-desc19
4 files changed, 0 insertions, 106 deletions
diff --git a/python/python-Levenshtein/README b/python/python-Levenshtein/README
deleted file mode 100644
index d931876c54..0000000000
--- a/python/python-Levenshtein/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Levenshtein Python extension and C library.
-
-The Levenshtein Python C extension module contains functions for fast
-computation of
-- Levenshtein (edit) distance, and edit operations
-- string similarity
-- approximate median strings, and generally string averaging
-- string sequence and set similarity
-It supports both normal and Unicode strings.
diff --git a/python/python-Levenshtein/python-Levenshtein.SlackBuild b/python/python-Levenshtein/python-Levenshtein.SlackBuild
deleted file mode 100644
index 07d2019e45..0000000000
--- a/python/python-Levenshtein/python-Levenshtein.SlackBuild
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for MySQL-python.
-
-# Written by Jick Nan (jick.nan@gmail.com)
-
-PRGNAM=python-Levenshtein
-VERSION=${VERSION:-0.10.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README.rst COPYING NEWS HISTORY.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-Levenshtein/python-Levenshtein.info b/python/python-Levenshtein/python-Levenshtein.info
deleted file mode 100644
index 6c42ac48b5..0000000000
--- a/python/python-Levenshtein/python-Levenshtein.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-Levenshtein"
-VERSION="0.10.2"
-HOMEPAGE="https://pypi.python.org/pypi/python-Levenshtein/"
-DOWNLOAD="https://pypi.python.org/packages/source/p/python-Levenshtein/python-Levenshtein-0.10.2.tar.gz"
-MD5SUM="c8af7296dc640abdf511614ee677bbb8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Janis Eisaks"
-EMAIL="jancs@dv.lv"
diff --git a/python/python-Levenshtein/slack-desc b/python/python-Levenshtein/slack-desc
deleted file mode 100644
index deea034f42..0000000000
--- a/python/python-Levenshtein/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-Levenshtein: python-Levenshtein (string distance calculation module)
-python-Levenshtein:
-python-Levenshtein: python-levenhstein is a C extension module for Python that can be
-python-Levenshtein: used for fast calculation of string distances with the Levenshtein
-python-Levenshtein: algorithm, as well as some other methods.
-python-Levenshtein:
-python-Levenshtein: The python-Levenshtein website can be found at:
-python-Levenshtein: https://pypi.python.org/pypi/python-Levenshtein/
-python-Levenshtein:
-python-Levenshtein:
-python-Levenshtein: