summaryrefslogtreecommitdiffstats
path: root/python/python-kerberos
diff options
context:
space:
mode:
author Thibaut Notteboom <thibaut.notteboom@gmail.com>2018-04-06 01:07:57 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-07 08:13:13 +0700
commite74fbea49f030bd78872a39ac21455fe05d2ca98 (patch)
treeea1135b6a5bc80dfeb241c5c54626979bdf473d7 /python/python-kerberos
parent0164892b17d335eca6e7733505d3ddc3801a598c (diff)
downloadslackbuilds-e74fbea49f030bd78872a39ac21455fe05d2ca98.tar.gz
slackbuilds-e74fbea49f030bd78872a39ac21455fe05d2ca98.tar.xz
python/python-kerberos: Updated for version 1.2.1 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/python-kerberos')
-rw-r--r--python/python-kerberos/python-kerberos.SlackBuild74
-rw-r--r--python/python-kerberos/python-kerberos.info10
2 files changed, 44 insertions, 40 deletions
diff --git a/python/python-kerberos/python-kerberos.SlackBuild b/python/python-kerberos/python-kerberos.SlackBuild
index e600bef8c8..71d6c6d032 100644
--- a/python/python-kerberos/python-kerberos.SlackBuild
+++ b/python/python-kerberos/python-kerberos.SlackBuild
@@ -1,38 +1,38 @@
#!/bin/sh
+# Slackware build script for python-kerberos
+
# Copyright (c) 2014 LEVAI Daniel
+# Copyright 2018 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
-# * Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-# * Redistributions of source code must retain the above copyright notice
-# this list of conditions and the following disclaimer.
-# * Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
#
-# THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES,
-# INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
-# AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
-# COPYRIGHT HOLDER BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
-# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Slackware build script for python-kerberos
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-kerberos
-VERSION=${VERSION:-1.1.5}
+VERSION=${VERSION:-1.2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCNAM=pykerberos
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -43,10 +43,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="LICENSE README"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,29 +57,35 @@ else
LIBDIRSUFFIX=""
fi
-DISTNAME=pykerberos
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $DISTNAME-$VERSION
-tar xvf $CWD/$DISTNAME-$VERSION.tar.gz
-cd $DISTNAME-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build || exit 1
+python setup.py install --root=$PKG
-python setup.py install --root $PKG || exit 1
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-kerberos/python-kerberos.info b/python/python-kerberos/python-kerberos.info
index 6d4b799015..cc903ec2a2 100644
--- a/python/python-kerberos/python-kerberos.info
+++ b/python/python-kerberos/python-kerberos.info
@@ -1,10 +1,10 @@
PRGNAM="python-kerberos"
-VERSION="1.1.5"
+VERSION="1.2.1"
HOMEPAGE="https://pypi.python.org/pypi/pykerberos"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pykerberos/pykerberos-1.1.5.tar.gz"
-MD5SUM="62a45589707a2beca325e193986c87af"
+DOWNLOAD="https://github.com/02strich/pykerberos/archive/v1.2.1/pykerberos-1.2.1.tar.gz"
+MD5SUM="1f3523b1af9f347fa67741f23c810b5b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="krb5"
-MAINTAINER="LEVAI Daniel"
-EMAIL="leva@ecentrum.hu"
+MAINTAINER="Thibaut Notteboom"
+EMAIL="thibaut.notteboom@gmail.com"