summaryrefslogtreecommitdiffstats
path: root/python/python-libtmux/python-libtmux.SlackBuild
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2022-09-24 02:40:53 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-09-25 13:59:44 +0700
commit89136be0fa57c32be0ffe403e36d5087dc44f23f (patch)
tree1fb941b809c526b7db77a2e3f6abb290966e1439 /python/python-libtmux/python-libtmux.SlackBuild
parentc4fcdfe3ebf893285ec0e0af4de6de0f48dc56ce (diff)
downloadslackbuilds-89136be0fa57c32be0ffe403e36d5087dc44f23f.tar.gz
slackbuilds-89136be0fa57c32be0ffe403e36d5087dc44f23f.tar.xz
python/python-libtmux: Updated for version 0.15.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-libtmux/python-libtmux.SlackBuild')
-rw-r--r--python/python-libtmux/python-libtmux.SlackBuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/python/python-libtmux/python-libtmux.SlackBuild b/python/python-libtmux/python-libtmux.SlackBuild
index 85d6d1a105..8a2b3ef400 100644
--- a/python/python-libtmux/python-libtmux.SlackBuild
+++ b/python/python-libtmux/python-libtmux.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python-libtmux
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2016-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -22,11 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220919 46and2: Updated version, new maintainer.
+# -build process changed
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-libtmux
-SRCNAM=$(echo $PRGNAM | cut -c8-14)
-VERSION=${VERSION:-0.10.3}
+SRCNAM=$(echo $PRGNAM | sed "s/python-//")
+VERSION=${VERSION:-0.15.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +84,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true