summaryrefslogtreecommitdiffstats
path: root/python/python-pmw
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/python-pmw
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
slackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python-pmw')
-rw-r--r--python/python-pmw/README12
-rw-r--r--python/python-pmw/python-pmw.SlackBuild90
-rw-r--r--python/python-pmw/python-pmw.info10
-rw-r--r--python/python-pmw/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/python/python-pmw/README b/python/python-pmw/README
new file mode 100644
index 0000000000..8363f1840d
--- /dev/null
+++ b/python/python-pmw/README
@@ -0,0 +1,12 @@
+python-pmw (Python Megawidgets, based on top of Tkinter)
+
+It is a toolkit for building high-level compound widgets in Python
+using the Tkinter module. It consists of a set of base classes and
+a library of flexible and extensible megawidgets built on this
+foundation. These megawidgets include notebooks, comboboxes,
+selection widgets, paned widgets, scrolled widgets and dialog
+windows.
+
+The base classes and most megawidgets were written by Greg McFarlane
+(current maintainer) and Peter Munnings. There are also several
+contributed megawidgets.
diff --git a/python/python-pmw/python-pmw.SlackBuild b/python/python-pmw/python-pmw.SlackBuild
new file mode 100644
index 0000000000..4b66fc0b95
--- /dev/null
+++ b/python/python-pmw/python-pmw.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for python-pmw
+
+# Copyright 2007-2009 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-pmw
+VERSION=${VERSION:-1.3.2}
+BUILD=${BUILD:-3}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+SRC_PRGNAM=Pmw
+SRC_SUBDIR=Pmw_1_3
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Python site-packages directory
+PYTHONDIR="/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages"
+
+# Exit on most errors
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRC_PRGNAM.$VERSION
+tar xvf $CWD/$SRC_PRGNAM.$VERSION.tar.gz
+cd $SRC_PRGNAM.$VERSION/src/$SRC_PRGNAM
+chown -R root:root . || true
+chmod -R u+w,go+r-w,a-s .
+
+# Move documentation files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv README $PKG/usr/doc/$PRGNAM-$VERSION
+mv $SRC_SUBDIR/doc $PKG/usr/doc/$PRGNAM-$VERSION/html
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Manual installation because python setup.py install seems to not be working
+mkdir -p $PKG/$PYTHONDIR/$SRC_PRGNAM/$SRC_SUBDIR
+cp -a $SRC_SUBDIR/{bin,contrib,demos,lib,tests,__init__.py} \
+ $PKG/$PYTHONDIR/$SRC_PRGNAM/$SRC_SUBDIR
+cp -a __init__.py Alpha_99_9_example $PKG/$PYTHONDIR/$SRC_PRGNAM
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-pmw/python-pmw.info b/python/python-pmw/python-pmw.info
new file mode 100644
index 0000000000..e117586b1c
--- /dev/null
+++ b/python/python-pmw/python-pmw.info
@@ -0,0 +1,10 @@
+PRGNAM="python-pmw"
+VERSION="1.3.2"
+HOMEPAGE="http://pmw.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/pmw/Pmw.1.3.2.tar.gz"
+MD5SUM="7f30886fe9885ab3cf85dac6ce1fbda5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="dsomero"
diff --git a/python/python-pmw/slack-desc b/python/python-pmw/slack-desc
new file mode 100644
index 0000000000..927d588af4
--- /dev/null
+++ b/python/python-pmw/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-pmw: python-pmw (Python Megawidgets, based on top of Tkinter)
+python-pmw:
+python-pmw: It is a toolkit for building high-level compound widgets in
+python-pmw: Python using the Tkinter module. It consists of a set of base
+python-pmw: classes and a library of flexible and extensible megawidgets
+python-pmw: built on this foundation. These megawidgets include notebooks,
+python-pmw: comboboxes, selection widgets, paned widgets, scrolled widgets
+python-pmw: and dialog windows.
+python-pmw:
+python-pmw: Homepage: http://pmw.sourceforge.net/
+python-pmw: