summaryrefslogtreecommitdiffstats
path: root/python/python-requests-kerberos
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:42 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:02 +0700
commit4ae2942e837b7f5e0e620d7a70f2af42eb6fecbb (patch)
tree25e8ffff3991bac986d3649c8446014790e29383 /python/python-requests-kerberos
parent4443d69af3184507386a22bc70d47d0bd554948d (diff)
downloadslackbuilds-4ae2942e837b7f5e0e620d7a70f2af42eb6fecbb.tar.gz
slackbuilds-4ae2942e837b7f5e0e620d7a70f2af42eb6fecbb.tar.xz
python/python-requests-kerberos: Renamed python2-requests-kerberos.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-requests-kerberos')
-rw-r--r--python/python-requests-kerberos/README3
-rw-r--r--python/python-requests-kerberos/python-requests-kerberos.SlackBuild89
-rw-r--r--python/python-requests-kerberos/python-requests-kerberos.info10
-rw-r--r--python/python-requests-kerberos/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/python/python-requests-kerberos/README b/python/python-requests-kerberos/README
deleted file mode 100644
index 0295cb546b..0000000000
--- a/python/python-requests-kerberos/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Requests is an HTTP library, written in Python, for human beings.
-This library adds optional Kerberos/GSSAPI authentication support and
-supports mutual authentication.
diff --git a/python/python-requests-kerberos/python-requests-kerberos.SlackBuild b/python/python-requests-kerberos/python-requests-kerberos.SlackBuild
deleted file mode 100644
index 5d21bd86f7..0000000000
--- a/python/python-requests-kerberos/python-requests-kerberos.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-requests-kerberos
-
-# Copyright 2015-2018 Thibaut Notteboom, Paris, FRANCE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-requests-kerberos
-VERSION=${VERSION:-0.12.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=requests-kerberos
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS HISTORY.rst LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-requests-kerberos/python-requests-kerberos.info b/python/python-requests-kerberos/python-requests-kerberos.info
deleted file mode 100644
index bdb54cb761..0000000000
--- a/python/python-requests-kerberos/python-requests-kerberos.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-requests-kerberos"
-VERSION="0.12.0"
-HOMEPAGE="https://github.com/requests/requests-kerberos"
-DOWNLOAD="https://github.com/requests/requests-kerberos/archive/v0.12.0/requests-kerberos-0.12.0.tar.gz"
-MD5SUM="5d2332620942087b0dc951fd734a8bac"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-kerberos cryptography"
-MAINTAINER="Thibaut Notteboom"
-EMAIL="thibaut.notteboom@gmail.com"
diff --git a/python/python-requests-kerberos/slack-desc b/python/python-requests-kerberos/slack-desc
deleted file mode 100644
index 02679d8ed3..0000000000
--- a/python/python-requests-kerberos/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-requests-kerberos: python-requests-kerberos (kerberos authen handler for requests)
-python-requests-kerberos:
-python-requests-kerberos:
-python-requests-kerberos: Requests is an HTTP library, written in Python, for human beings.
-python-requests-kerberos: This library adds optional Kerberos/GSSAPI authentication support and
-python-requests-kerberos: supports mutual authentication.
-python-requests-kerberos:
-python-requests-kerberos:
-python-requests-kerberos:
-python-requests-kerberos:
-python-requests-kerberos: