summaryrefslogtreecommitdiffstats
path: root/python/python-requests/python-requests.SlackBuild
diff options
context:
space:
mode:
author Thibaut Notteboom <thibaut.notteboom@gmail.com>2015-03-15 07:59:10 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-15 07:59:10 +0700
commitb6c0f3a24a55533a04cc4b53bc30cf637e75918b (patch)
treeef291afc4d2e02d8e10e5835b35235ef301a2f6e /python/python-requests/python-requests.SlackBuild
parentdb80bc979d149665ab99d08b249f3e3324eac80f (diff)
downloadslackbuilds-b6c0f3a24a55533a04cc4b53bc30cf637e75918b.tar.gz
slackbuilds-b6c0f3a24a55533a04cc4b53bc30cf637e75918b.tar.xz
python/python-requests: Updated for version 2.5.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-requests/python-requests.SlackBuild')
-rw-r--r--python/python-requests/python-requests.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/python-requests/python-requests.SlackBuild b/python/python-requests/python-requests.SlackBuild
index f24f49b7c9..8219b638e0 100644
--- a/python/python-requests/python-requests.SlackBuild
+++ b/python/python-requests/python-requests.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-requests
-# Copyright 2013-2014 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2013-2015 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-requests
-VERSION=${VERSION:-2.4.3}
+VERSION=${VERSION:-2.5.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,6 +73,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
HISTORY.rst LICENSE NOTICE PKG-INFO README.rst \