summaryrefslogtreecommitdiffstats
path: root/python/python3-isort
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2022-12-20 18:46:01 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-23 10:11:51 +0700
commit6a601a367f238a94524f5f33ba76aece0ecf8fc0 (patch)
tree5a7ba9c78b6a11b9ab2372731f2451268a604756 /python/python3-isort
parent951cb40ed8eb0f73ba13c923dea9749fdd60c064 (diff)
downloadslackbuilds-6a601a367f238a94524f5f33ba76aece0ecf8fc0.tar.gz
slackbuilds-6a601a367f238a94524f5f33ba76aece0ecf8fc0.tar.xz
python/python3-isort: Updated for version 5.11.3.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-isort')
-rw-r--r--python/python3-isort/README3
-rw-r--r--python/python3-isort/python3-isort.SlackBuild11
-rw-r--r--python/python3-isort/python3-isort.info10
-rw-r--r--python/python3-isort/slack-desc12
4 files changed, 16 insertions, 20 deletions
diff --git a/python/python3-isort/README b/python/python3-isort/README
index 34feffb970..5369c75f88 100644
--- a/python/python3-isort/README
+++ b/python/python3-isort/README
@@ -2,6 +2,3 @@ isort is a Python utility/library to sort imports alphabetically, and
automatically separated into sections. It provides a command line
utility, Python library and plugins for various editors to quickly sort
all your imports.
-
-This Python 3 version of the isort package doesn't contain the command
-line utility. Install Python 2 isort package to get the utility.
diff --git a/python/python3-isort/python3-isort.SlackBuild b/python/python3-isort/python3-isort.SlackBuild
index 4a7b8eec25..d929624828 100644
--- a/python/python3-isort/python3-isort.SlackBuild
+++ b/python/python3-isort/python3-isort.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python3-isort
+# Copyright 2022 Dimitris Zlatanidis Orestiada, Greece
# Copyright 2018 Markus Rinne Finland
# All rights reserved.
#
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-isort
SRCNAM=isort
-VERSION=${VERSION:-5.10.1}
+VERSION=${VERSION:-5.11.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,16 +83,14 @@ find -L . \
python3 setup.py install --root=$PKG
-# Remove isort binary, because it is contained in Python 2 version of isort package.
-rm $PKG/usr/bin/isort
+# Rename isort binary, because it is contained in Python 2 version of isort package.
+mv $PKG/usr/bin/isort $PKG/usr/bin/isort3
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- PKG-INFO README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-isort/python3-isort.info b/python/python3-isort/python3-isort.info
index 87e471c71d..f830d9c150 100644
--- a/python/python3-isort/python3-isort.info
+++ b/python/python3-isort/python3-isort.info
@@ -1,10 +1,10 @@
PRGNAM="python3-isort"
-VERSION="5.10.1"
+VERSION="5.11.3"
HOMEPAGE="https://timothycrosley.github.io/isort/"
-DOWNLOAD="https://files.pythonhosted.org/packages/ab/e9/964cb0b2eedd80c92f5172f1f8ae0443781a9d461c1372a3ce5762489593/isort-5.10.1.tar.gz"
-MD5SUM="717294d0a9017b27bd46b1c946b39bd0"
+DOWNLOAD="https://files.pythonhosted.org/packages/e2/43/d99899bfa24a3914f0318536918ab8c91c09350b5482e4e9bb7291840ae3/isort-5.11.3.tar.gz"
+MD5SUM="66fbcee3d4dc83e8e434b1566086f1b1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Markus Rinne"
-EMAIL="markus.ka.rinne@gmail.com"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python3-isort/slack-desc b/python/python3-isort/slack-desc
index 0b62fc23bd..6aad05d2cd 100644
--- a/python/python3-isort/slack-desc
+++ b/python/python3-isort/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
python3-isort: python3-isort (sort imports alphabetically)
python3-isort:
-python3-isort: isort is a Python utility/library to sort imports alphabetically, and
-python3-isort: automatically separated into sections. It provides a command line
-python3-isort: utility, Python library and plugins for various editors to quickly
-python3-isort: sort all your imports.
+python3-isort: isort is a Python utility/library to sort imports alphabetically,
+python3-isort: and automatically separated into sections. It provides a command
+python3-isort: line utility, Python library and plugins for various editors to
+python3-isort: quickly sort all your imports.
+python3-isort:
+python3-isort: Homepage: https://pycqa.github.io/isort
python3-isort:
-python3-isort: This Python 3 version of the isort package doesn't contain the command
-python3-isort: line utility. Install Python 2 isort package to get the utility.
python3-isort:
python3-isort: