summaryrefslogtreecommitdiffstats
path: root/python/python3-ptyprocess
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2017-04-16 18:03:36 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-16 18:03:36 +0700
commitffd334880294a18c167656a27d387f3f4d292b0f (patch)
treee031906071ea251019f808a61b93dbbeb18e5324 /python/python3-ptyprocess
parent8ae285310e0a66b1e60527601316c968e5af1911 (diff)
downloadslackbuilds-ffd334880294a18c167656a27d387f3f4d292b0f.tar.gz
slackbuilds-ffd334880294a18c167656a27d387f3f4d292b0f.tar.xz
python/python3-ptyprocess: Added (subprocesses in pseudo terminals).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-ptyprocess')
-rw-r--r--python/python3-ptyprocess/README8
-rw-r--r--python/python3-ptyprocess/python3-ptyprocess.SlackBuild89
-rw-r--r--python/python3-ptyprocess/python3-ptyprocess.info10
-rw-r--r--python/python3-ptyprocess/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/python3-ptyprocess/README b/python/python3-ptyprocess/README
new file mode 100644
index 0000000000..e80b0e9429
--- /dev/null
+++ b/python/python3-ptyprocess/README
@@ -0,0 +1,8 @@
+ptyprocess (python module)
+
+Launch a subprocess in a pseudo terminal (pty), and interact with
+both the process and its pty.
+Sometimes, piping stdin and stdout is not enough. There might be
+a password prompt that doesn’t read from stdin, output that changes
+when it’s going to a pipe rather than a terminal, or curses-style
+interfaces that rely on a terminal.
diff --git a/python/python3-ptyprocess/python3-ptyprocess.SlackBuild b/python/python3-ptyprocess/python3-ptyprocess.SlackBuild
new file mode 100644
index 0000000000..8f0ed1f04c
--- /dev/null
+++ b/python/python3-ptyprocess/python3-ptyprocess.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for python3-ptyprocess
+
+# Copyright 2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=ptyprocess
+PRGNAM=python3-$SRCNAM
+VERSION=${VERSION:-0.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION/ -type f -exec chmod 644 {} \;
+chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-ptyprocess/python3-ptyprocess.info b/python/python3-ptyprocess/python3-ptyprocess.info
new file mode 100644
index 0000000000..fc65d80485
--- /dev/null
+++ b/python/python3-ptyprocess/python3-ptyprocess.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-ptyprocess"
+VERSION="0.5.1"
+HOMEPAGE="https://pypi.python.org/pypi/ptyprocess"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/ptyprocess/ptyprocess-0.5.1.tar.gz"
+MD5SUM="94e537122914cc9ec9c1eadcd36e73a1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-ptyprocess/slack-desc b/python/python3-ptyprocess/slack-desc
new file mode 100644
index 0000000000..3737ed942a
--- /dev/null
+++ b/python/python3-ptyprocess/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-ptyprocess: python3-ptyprocess (subprocesses in pseudo terminals for Python 3)
+python3-ptyprocess:
+python3-ptyprocess: Launch a subprocess in a pseudo terminal (pty), and interact with
+python3-ptyprocess: both the process and its pty.
+python3-ptyprocess: Sometimes, piping stdin and stdout is not enough. There might be
+python3-ptyprocess: a password prompt that doesn’t read from stdin, output that changes
+python3-ptyprocess: when it’s going to a pipe rather than a terminal, or curses-style
+python3-ptyprocess: interfaces that rely on a terminal.
+python3-ptyprocess:
+python3-ptyprocess: Project URL: https://pypi.python.org/pypi/ptyprocess
+python3-ptyprocess: