summaryrefslogtreecommitdiffstats
path: root/python/six
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2017-03-13 11:18:33 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-18 06:59:21 +0700
commit8674dabb940f6de4901008a27af0d99ff84e76ac (patch)
treefb80e6ad3a1945ee06d35c99c43ffa2916f44be5 /python/six
parent399b01e18c840894b562edaa636dd6fdc91dce30 (diff)
downloadslackbuilds-8674dabb940f6de4901008a27af0d99ff84e76ac.tar.gz
slackbuilds-8674dabb940f6de4901008a27af0d99ff84e76ac.tar.xz
python/six: make installing python3 bindings a custom option
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python/six')
-rw-r--r--python/six/README8
-rw-r--r--python/six/six.SlackBuild4
2 files changed, 7 insertions, 5 deletions
diff --git a/python/six/README b/python/six/README
index 4f3306550f..e968d08d27 100644
--- a/python/six/README
+++ b/python/six/README
@@ -3,6 +3,8 @@ smoothing over the differences between the Python versions with the goal of
writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
-Optional: html documentation and man pages will be installed if Pygments and
-Sphinx are installed. Python3 module will be built if Python3 is installed.
-Pysetuptools is an optional build time dependency.
+Optional dependencies: python3 and Sphinx
+
+Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
+
+ # PYTHON3=yes ./six.SlackBuild
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
index b1c25a1eaf..69506ba6cc 100644
--- a/python/six/six.SlackBuild
+++ b/python/six/six.SlackBuild
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -57,7 +57,7 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi