summaryrefslogtreecommitdiffstats
path: root/python/unrardll
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2017-07-16 11:10:28 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-22 06:55:58 +0700
commitf251dac0ebc0525ff8a1d5fa9c42bcb085aa08f7 (patch)
tree3fd61807525acf69a32c53fc18194b0cea60df54 /python/unrardll
parentc48e73413788beffeeb47f852eed6afabe2b074c (diff)
downloadslackbuilds-f251dac0ebc0525ff8a1d5fa9c42bcb085aa08f7.tar.gz
slackbuilds-f251dac0ebc0525ff8a1d5fa9c42bcb085aa08f7.tar.xz
python/unrardll: Added (enable unraring of files in python).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/unrardll')
-rw-r--r--python/unrardll/README1
-rw-r--r--python/unrardll/slack-desc19
-rw-r--r--python/unrardll/unrardll.SlackBuild71
-rw-r--r--python/unrardll/unrardll.info10
4 files changed, 101 insertions, 0 deletions
diff --git a/python/unrardll/README b/python/unrardll/README
new file mode 100644
index 0000000000..b76e1109f2
--- /dev/null
+++ b/python/unrardll/README
@@ -0,0 +1 @@
+Wrap the Unrar DLL to enable unraring of files in python.
diff --git a/python/unrardll/slack-desc b/python/unrardll/slack-desc
new file mode 100644
index 0000000000..9401bc6085
--- /dev/null
+++ b/python/unrardll/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+unrardll: unrardll (enable unraring of files in python)
+unrardll:
+unrardll: Wrap the Unrar DLL to enable unraring of files in python.
+unrardll:
+unrardll: Homepage: https://github.com/kovidgoyal/unrardll
+unrardll:
+unrardll:
+unrardll:
+unrardll:
+unrardll:
+unrardll:
diff --git a/python/unrardll/unrardll.SlackBuild b/python/unrardll/unrardll.SlackBuild
new file mode 100644
index 0000000000..04fe739113
--- /dev/null
+++ b/python/unrardll/unrardll.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for unrardll
+
+# Copyright 2017 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=unrardll
+VERSION=${VERSION:-0.1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/unrardll/unrardll.info b/python/unrardll/unrardll.info
new file mode 100644
index 0000000000..70cd57f5d9
--- /dev/null
+++ b/python/unrardll/unrardll.info
@@ -0,0 +1,10 @@
+PRGNAM="unrardll"
+VERSION="0.1.3"
+HOMEPAGE="https://github.com/kovidgoyal/unrardll"
+DOWNLOAD="https://pypi.python.org/packages/78/e1/f5941702c698826782974ba889570a405916dbeb068ab4ee88fc22a67db6/unrardll-0.1.3.tar.gz"
+MD5SUM="8830d810f637eefbe829e10488496b6d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="unrar"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"