summaryrefslogtreecommitdiffstats
path: root/python/vcversioner
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2017-05-07 17:58:51 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-05-13 06:58:57 +0700
commit05009f247ea8b7fef5086551faec454a6ca13b4b (patch)
treed278eccde92f4e6cfafb25f98e6bd83956d3bc38 /python/vcversioner
parent000111b2219cbbb7a0f540507d4c21b4c7a3d77a (diff)
downloadslackbuilds-05009f247ea8b7fef5086551faec454a6ca13b4b.tar.gz
slackbuilds-05009f247ea8b7fef5086551faec454a6ca13b4b.tar.xz
python/vcversioner: Added (use vc tags to discover version numbers).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/vcversioner')
-rw-r--r--python/vcversioner/README7
-rw-r--r--python/vcversioner/slack-desc19
-rw-r--r--python/vcversioner/vcversioner.SlackBuild90
-rw-r--r--python/vcversioner/vcversioner.info10
4 files changed, 126 insertions, 0 deletions
diff --git a/python/vcversioner/README b/python/vcversioner/README
new file mode 100644
index 0000000000..620c93239d
--- /dev/null
+++ b/python/vcversioner/README
@@ -0,0 +1,7 @@
+vcversioner (use version control tags to discover version numbers)
+
+Write a setup.py with no version information specified, and vcversioner
+will find a recent, properly-formatted VCS tag and extract a version
+from it.
+
+Optional dependency: python3
diff --git a/python/vcversioner/slack-desc b/python/vcversioner/slack-desc
new file mode 100644
index 0000000000..a123e08033
--- /dev/null
+++ b/python/vcversioner/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+vcversioner: vcversioner (use version control tags to discover version numbers)
+vcversioner:
+vcversioner: Write a setup.py with no version information specified, and
+vcversioner: vcversioner will find a recent, properly-formatted VCS tag and extract
+vcversioner: a version from it.
+vcversioner:
+vcversioner: https://pypi.python.org/pypi/vcversioner
+vcversioner:
+vcversioner:
+vcversioner:
+vcversioner:
diff --git a/python/vcversioner/vcversioner.SlackBuild b/python/vcversioner/vcversioner.SlackBuild
new file mode 100644
index 0000000000..d94f463683
--- /dev/null
+++ b/python/vcversioner/vcversioner.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for vcversioner
+
+# Copyright 2017 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=vcversioner
+VERSION=${VERSION:-2.16.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/vcversioner/vcversioner.info b/python/vcversioner/vcversioner.info
new file mode 100644
index 0000000000..1e6da48e93
--- /dev/null
+++ b/python/vcversioner/vcversioner.info
@@ -0,0 +1,10 @@
+PRGNAM="vcversioner"
+VERSION="2.16.0.0"
+HOMEPAGE="https://pypi.python.org/pypi/vcversioner"
+DOWNLOAD="https://pypi.python.org/packages/c5/cc/33162c0a7b28a4d8c83da07bc2b12cee58c120b4a9e8bba31c41c8d35a16/vcversioner-2.16.0.0.tar.gz"
+MD5SUM="aab6ef5e0cf8614a1b1140ed5b7f107d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"