summaryrefslogtreecommitdiffstats
path: root/python/veryprettytable
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2017-02-17 11:23:09 +0000
committer David Spencer <idlemoor@slackbuilds.org>2017-02-17 21:52:08 +0000
commita2995dc195e4ad45a6008dfd05cb822f6493fb61 (patch)
treee9c6148d8d4ba8c7f8bfc3fa9c584b628db13f34 /python/veryprettytable
parentd6bef62cfdceabff1594d45f36fc6eb2ba31ac28 (diff)
downloadslackbuilds-a2995dc195e4ad45a6008dfd05cb822f6493fb61.tar.gz
slackbuilds-a2995dc195e4ad45a6008dfd05cb822f6493fb61.tar.xz
python/veryprettytable: Added (Python tabular library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/veryprettytable')
-rw-r--r--python/veryprettytable/README2
-rw-r--r--python/veryprettytable/slack-desc19
-rw-r--r--python/veryprettytable/veryprettytable.SlackBuild89
-rw-r--r--python/veryprettytable/veryprettytable.info10
4 files changed, 120 insertions, 0 deletions
diff --git a/python/veryprettytable/README b/python/veryprettytable/README
new file mode 100644
index 0000000000..1b465e2d8b
--- /dev/null
+++ b/python/veryprettytable/README
@@ -0,0 +1,2 @@
+A simple Python library for easily displaying tabular data in a visually
+appealing ASCII table format.
diff --git a/python/veryprettytable/slack-desc b/python/veryprettytable/slack-desc
new file mode 100644
index 0000000000..0a1389b0ad
--- /dev/null
+++ b/python/veryprettytable/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+veryprettytable: veryprettytable (Python tabular library)
+veryprettytable:
+veryprettytable: A simple Python library for easily displaying tabular data in
+veryprettytable: a visually appealing ASCII table format.
+veryprettytable:
+veryprettytable: Homepage: https://github.com/smeggingsmegger/VeryPrettyTable
+veryprettytable:
+veryprettytable:
+veryprettytable:
+veryprettytable:
+veryprettytable:
diff --git a/python/veryprettytable/veryprettytable.SlackBuild b/python/veryprettytable/veryprettytable.SlackBuild
new file mode 100644
index 0000000000..b7d041d9d9
--- /dev/null
+++ b/python/veryprettytable/veryprettytable.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for veryprettytable
+
+# Copyright 2017 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=veryprettytable
+VERSION=${VERSION:-0.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG COPYING PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/veryprettytable/veryprettytable.info b/python/veryprettytable/veryprettytable.info
new file mode 100644
index 0000000000..47fc4c3c07
--- /dev/null
+++ b/python/veryprettytable/veryprettytable.info
@@ -0,0 +1,10 @@
+PRGNAM="veryprettytable"
+VERSION="0.8.1"
+HOMEPAGE="https://github.com/smeggingsmegger/VeryPrettyTable"
+DOWNLOAD="https://pypi.python.org/packages/50/43/d2695870d2b175be4c8a8f2f150626c6aec11469eeb6af284347b4bcf8ad/veryprettytable-0.8.1.tar.gz"
+MD5SUM="9c166015f2429ea622cfd408ffc1c651"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="termcolor colorama"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"