summaryrefslogtreecommitdiffstats
path: root/python/virtualenvwrapper
diff options
context:
space:
mode:
author vvoody <vvoodywang@gmail.com>2012-12-14 19:45:53 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2012-12-15 15:13:39 +0100
commitc54f682596551b8fbd81914a18fd37599cb7e231 (patch)
tree6c759983dbefeb285060cb247efa767e2a14916c /python/virtualenvwrapper
parent68e0061b6787008a5f1d73cb6bf0e4d50b4a25de (diff)
downloadslackbuilds-c54f682596551b8fbd81914a18fd37599cb7e231.tar.gz
slackbuilds-c54f682596551b8fbd81914a18fd37599cb7e231.tar.xz
python/virtualenvwrapper: Added (virtualenv extensions).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/virtualenvwrapper')
-rw-r--r--python/virtualenvwrapper/README9
-rw-r--r--python/virtualenvwrapper/slack-desc19
-rw-r--r--python/virtualenvwrapper/virtualenvwrapper.SlackBuild90
-rw-r--r--python/virtualenvwrapper/virtualenvwrapper.info10
4 files changed, 128 insertions, 0 deletions
diff --git a/python/virtualenvwrapper/README b/python/virtualenvwrapper/README
new file mode 100644
index 0000000000..3c0158409b
--- /dev/null
+++ b/python/virtualenvwrapper/README
@@ -0,0 +1,9 @@
+virtualenvwrapper (Extensions to Ian Bicking's virtualenv tool)
+
+virtualenvwrapper is a set of extensions to Ian Bicking's virtualenv
+tool for creating isolated Python development environments.
+
+The extensions include wrappers for creating and deleting virtual
+environments and otherwise managing your development workflow,
+making it easier to work on more than one project at a time without
+introducing conflicts in their dependencies.
diff --git a/python/virtualenvwrapper/slack-desc b/python/virtualenvwrapper/slack-desc
new file mode 100644
index 0000000000..9270cd52bc
--- /dev/null
+++ b/python/virtualenvwrapper/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+virtualenvwrapper: virtualenvwrapper (Extensions to Ian Bicking's virtualenv tool)
+virtualenvwrapper:
+virtualenvwrapper: virtualenvwrapper is a set of extensions to Ian Bicking's virtualenv
+virtualenvwrapper: tool for creating isolated Python development environments.
+virtualenvwrapper:
+virtualenvwrapper: The extensions include wrappers for creating and deleting virtual
+virtualenvwrapper: environments and otherwise managing your development workflow,
+virtualenvwrapper: making it easier to work on more than one project at a time without
+virtualenvwrapper: introducing conflicts in their dependencies.
+virtualenvwrapper:
+virtualenvwrapper: Homepage: http://www.doughellmann.com/projects/virtualenvwrapper/
diff --git a/python/virtualenvwrapper/virtualenvwrapper.SlackBuild b/python/virtualenvwrapper/virtualenvwrapper.SlackBuild
new file mode 100644
index 0000000000..29f81c3d2d
--- /dev/null
+++ b/python/virtualenvwrapper/virtualenvwrapper.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for virtualenvwrapper
+
+# Copyright 2012 vvoody <vvoodywang@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=virtualenvwrapper
+VERSION=${VERSION:-3.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+# Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/virtualenvwrapper/virtualenvwrapper.info b/python/virtualenvwrapper/virtualenvwrapper.info
new file mode 100644
index 0000000000..f580a8a8c0
--- /dev/null
+++ b/python/virtualenvwrapper/virtualenvwrapper.info
@@ -0,0 +1,10 @@
+PRGNAM="virtualenvwrapper"
+VERSION="3.6"
+HOMEPAGE="http://www.doughellmann.com/projects/virtualenvwrapper/"
+DOWNLOAD="http://pypi.python.org/packages/source/v/virtualenvwrapper/virtualenvwrapper-3.6.tar.gz"
+MD5SUM="57d78305b75750a40985f206c80a280f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="virtualenv"
+MAINTAINER="vvoody"
+EMAIL="vvoodywang@gmail.com"