summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2018-02-03 20:07:29 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-02-10 08:09:38 +0700
commit015b0946de7bb6a7ecb6224bd869df4223c4950e (patch)
tree616db38d8a5911516178e531b8a82d5b5b206840 /python
parent8b0838a28b5fdb6700c3c6866fd02db74cea3fa6 (diff)
downloadslackbuilds-015b0946de7bb6a7ecb6224bd869df4223c4950e.tar.gz
slackbuilds-015b0946de7bb6a7ecb6224bd869df4223c4950e.tar.xz
python/pycodestyle: Added python3 support.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/pycodestyle/README2
-rw-r--r--python/pycodestyle/pycodestyle.SlackBuild5
2 files changed, 7 insertions, 0 deletions
diff --git a/python/pycodestyle/README b/python/pycodestyle/README
index 878812eec3..973fdfaf9b 100644
--- a/python/pycodestyle/README
+++ b/python/pycodestyle/README
@@ -1,2 +1,4 @@
pycodestyle is a tool to check your Python code against some of the
style conventions in PEP 8.
+
+python3 is an optional dependency (autodetected).
diff --git a/python/pycodestyle/pycodestyle.SlackBuild b/python/pycodestyle/pycodestyle.SlackBuild
index 35769e61ab..508181d56e 100644
--- a/python/pycodestyle/pycodestyle.SlackBuild
+++ b/python/pycodestyle/pycodestyle.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true