summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2016-07-30 10:49:56 -0700
committer David Spencer <idlemoor@slackbuilds.org>2016-08-05 18:10:51 +0100
commit99be0d29036f7e3822ca885fcc1b600a6925f2a7 (patch)
treef90d0aec8ccb08f96162936ec195764903e95ae7 /python
parent3bbcfb4e6f838cda7a16037066965ac4effdb86d (diff)
downloadslackbuilds-99be0d29036f7e3822ca885fcc1b600a6925f2a7.tar.gz
slackbuilds-99be0d29036f7e3822ca885fcc1b600a6925f2a7.tar.xz
python/lxml: Updated for version 3.6.1
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python')
-rw-r--r--python/lxml/README9
-rw-r--r--python/lxml/lxml.SlackBuild14
-rw-r--r--python/lxml/lxml.info8
3 files changed, 18 insertions, 13 deletions
diff --git a/python/lxml/README b/python/lxml/README
index 5772fe694a..99f8dc670b 100644
--- a/python/lxml/README
+++ b/python/lxml/README
@@ -2,5 +2,10 @@ lxml is a Pythonic binding for the libxml2 and libxslt libraries.
It is unique in that it combines the speed and feature completeness
of these libraries with the simplicity of a native Python API.
-python3 is an optional build dependency.
-cssselect and html5lib are optional runtime dependencies.
+Optional dependencies: python3, BeautifulSoup and cssselect
+
+BeautifulSoup can be used in place of BeautifulSoup4.
+
+Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
+
+ # PYTHON3=yes ./lxml.SlackBuild
diff --git a/python/lxml/lxml.SlackBuild b/python/lxml/lxml.SlackBuild
index 3db14f8981..f3a1df3f72 100644
--- a/python/lxml/lxml.SlackBuild
+++ b/python/lxml/lxml.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for lxml
-# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lxml
-VERSION=${VERSION:-3.6.0}
+VERSION=${VERSION:-3.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,9 +55,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -68,7 +68,7 @@ find -L . \
python setup.py build --with-unicode-strings
python setup.py install --skip-build --root=$PKG
-if $(python3 -c 'import os' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py build --with-unicode-strings
python3 setup.py install --skip-build --root=$PKG
fi
@@ -77,7 +77,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt PKG-INFO doc/licenses/* doc/FAQ.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt doc/licenses/* doc/FAQ.txt $PKG/usr/doc/$PRGNAM-$VERSION
rm $PKG/usr/doc/$PRGNAM-$VERSION/version.txt
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/lxml/lxml.info b/python/lxml/lxml.info
index 6d5b893b41..9eb8dc592a 100644
--- a/python/lxml/lxml.info
+++ b/python/lxml/lxml.info
@@ -1,10 +1,10 @@
PRGNAM="lxml"
-VERSION="3.6.0"
+VERSION="3.6.1"
HOMEPAGE="http://lxml.de/"
-DOWNLOAD="http://pypi.python.org/packages/source/l/lxml/lxml-3.6.0.tar.gz"
-MD5SUM="5957cc384bd6e83934be35c057ec03b6"
+DOWNLOAD="https://github.com/lxml/lxml/archive/lxml-3.6.1/lxml-lxml-3.6.1.tar.gz"
+MD5SUM="d112d959364a81044a2b15815ab2ba58"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="BeautifulSoup"
+REQUIRES="BeautifulSoup4 html5lib"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"