summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-17 01:03:41 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-07-22 06:55:32 +0700
commit9cea044e3485af4af4794808af97d7c6fde3c9a4 (patch)
tree699786aa733191eb5f6aca0d44614e05f254932c /python
parent126c3590cd92da62b3dab53d54b2ed43490a20ca (diff)
downloadslackbuilds-9cea044e3485af4af4794808af97d7c6fde3c9a4.tar.gz
slackbuilds-9cea044e3485af4af4794808af97d7c6fde3c9a4.tar.xz
python/idna: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/idna/idna.SlackBuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/python/idna/idna.SlackBuild b/python/idna/idna.SlackBuild
index c8a3b3f942..9072121cfd 100644
--- a/python/idna/idna.SlackBuild
+++ b/python/idna/idna.SlackBuild
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true