summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2018-03-30 23:37:18 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-31 07:41:41 +0700
commitf285584037a9d7c0dab04ec0b20f05e394d702ab (patch)
tree4e4b2715339b5205d2862eba895cdbddc5ab3471 /python
parent22be0e94587f3cedd466459ee0fd3e5f01ff56f9 (diff)
downloadslackbuilds-f285584037a9d7c0dab04ec0b20f05e394d702ab.tar.gz
slackbuilds-f285584037a9d7c0dab04ec0b20f05e394d702ab.tar.xz
python/python-argopt: Added (doc to argparse driven by docopt).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-argopt/README1
-rw-r--r--python/python-argopt/python-argopt.SlackBuild92
-rw-r--r--python/python-argopt/python-argopt.info10
-rw-r--r--python/python-argopt/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/python-argopt/README b/python/python-argopt/README
new file mode 100644
index 0000000000..d7089b5439
--- /dev/null
+++ b/python/python-argopt/README
@@ -0,0 +1 @@
+python-argopt - Define your command line interface (CLI) from a docstring
diff --git a/python/python-argopt/python-argopt.SlackBuild b/python/python-argopt/python-argopt.SlackBuild
new file mode 100644
index 0000000000..b582e1a977
--- /dev/null
+++ b/python/python-argopt/python-argopt.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for python-argopt
+
+# Copyright 2018 Andrew Clemons, Wellington New Zealand
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-argopt
+SRCNAM="$(echo "$PRGNAM" | cut -d- -f2)"
+VERSION=${VERSION:-0.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s/\\(install_requires=\\)\\['argparse'\\]/\\1[]/g" setup.py
+
+python setup.py install --root=$PKG
+
+if python3 -c 'import sys' 2> /dev/null ; then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENCE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-argopt/python-argopt.info b/python/python-argopt/python-argopt.info
new file mode 100644
index 0000000000..e60132cb16
--- /dev/null
+++ b/python/python-argopt/python-argopt.info
@@ -0,0 +1,10 @@
+PRGNAM="python-argopt"
+VERSION="0.4.0"
+HOMEPAGE="https://github.com/casperdcl/argopt"
+DOWNLOAD="https://github.com/casperdcl/argopt/archive/v0.4.0/argopt-0.4.0.tar.gz"
+MD5SUM="574b2c3504b163e4d52d1677f279aabe"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"
diff --git a/python/python-argopt/slack-desc b/python/python-argopt/slack-desc
new file mode 100644
index 0000000000..e924626675
--- /dev/null
+++ b/python/python-argopt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-argopt: python-argopt (doc to argparse driven by docopt)
+python-argopt:
+python-argopt: Define your command line interface (CLI) from a docstring (rather
+python-argopt: than the other way around).
+python-argopt:
+python-argopt: https://pypi.python.org/pypi/argopt
+python-argopt:
+python-argopt:
+python-argopt:
+python-argopt:
+python-argopt: