summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-04-28 22:52:23 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-28 22:52:23 +0700
commitfa8a7d66175d2ee330a68387bca9ab1e1e7b859a (patch)
treee9fbb11c41f236f5e7bc9e5fcfb289e6446fce15 /python
parentdd5d11bed74521424ba51c8aafd243c641d78283 (diff)
downloadslackbuilds-fa8a7d66175d2ee330a68387bca9ab1e1e7b859a.tar.gz
slackbuilds-fa8a7d66175d2ee330a68387bca9ab1e1e7b859a.tar.xz
python/PyGithub: Added (Library to use Github API v3).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/PyGithub/PyGithub.SlackBuild85
-rw-r--r--python/PyGithub/PyGithub.info10
-rw-r--r--python/PyGithub/README1
-rw-r--r--python/PyGithub/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/PyGithub/PyGithub.SlackBuild b/python/PyGithub/PyGithub.SlackBuild
new file mode 100644
index 0000000000..ed3bd5accc
--- /dev/null
+++ b/python/PyGithub/PyGithub.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for PyGithub
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PyGithub
+VERSION=${VERSION:-1.24.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/PyGithub/PyGithub.info b/python/PyGithub/PyGithub.info
new file mode 100644
index 0000000000..0ddcc1ecbe
--- /dev/null
+++ b/python/PyGithub/PyGithub.info
@@ -0,0 +1,10 @@
+PRGNAM="PyGithub"
+VERSION="1.24.1"
+HOMEPAGE="http://jacquev6.github.io/PyGithub/v1/index.html"
+DOWNLOAD="https://pypi.python.org/packages/source/P/PyGithub/PyGithub-1.24.1.tar.gz"
+MD5SUM="bf15aa34ee8cd75af9a6ae46c71f73cf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/PyGithub/README b/python/PyGithub/README
new file mode 100644
index 0000000000..c7eb44798d
--- /dev/null
+++ b/python/PyGithub/README
@@ -0,0 +1 @@
+PyGithub is a Python library to access the full Github API v3.
diff --git a/python/PyGithub/slack-desc b/python/PyGithub/slack-desc
new file mode 100644
index 0000000000..ecb429250e
--- /dev/null
+++ b/python/PyGithub/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyGithub: PyGithub (Library to use Github API v3)
+PyGithub:
+PyGithub: PyGithub is a Python library to access the full Github API v3.
+PyGithub:
+PyGithub: Homepage: http://jacquev6.github.io/PyGithub/v1/index.html
+PyGithub:
+PyGithub:
+PyGithub:
+PyGithub:
+PyGithub:
+PyGithub: