summaryrefslogtreecommitdiffstats
path: root/system/flexbackup
diff options
context:
space:
mode:
author klaatu <klaatu@member.fsf.org>2013-06-30 01:09:27 -0500
committer Erik Hanson <erik@slackbuilds.org>2013-06-30 01:09:27 -0500
commit28a41c331f37275da70b1ca844227f37c7c2be5f (patch)
treed992701049334b7d2f2346c4d4af8aab54acb688 /system/flexbackup
parent05fb5f2bc2c6114d18a28bc3b536056759dd080d (diff)
downloadslackbuilds-28a41c331f37275da70b1ca844227f37c7c2be5f.tar.gz
slackbuilds-28a41c331f37275da70b1ca844227f37c7c2be5f.tar.xz
system/flexbackup: Added (a flexible backup tool)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'system/flexbackup')
-rw-r--r--system/flexbackup/README16
-rw-r--r--system/flexbackup/doinst.sh14
-rw-r--r--system/flexbackup/flexbackup.SlackBuild65
-rw-r--r--system/flexbackup/flexbackup.info10
-rw-r--r--system/flexbackup/slack-desc19
5 files changed, 124 insertions, 0 deletions
diff --git a/system/flexbackup/README b/system/flexbackup/README
new file mode 100644
index 0000000000..437915b26e
--- /dev/null
+++ b/system/flexbackup/README
@@ -0,0 +1,16 @@
+Flexbackup is for you if you have a single or small number of
+machines, amanda is "too much", and tarring things up by hand isn't
+nearly enough.
+
+Features:
+ o Easy to configure
+ o Uses dump, afio, GNU tar, cpio, star, pax, or zip archivers
+ o Full and numbered levels of incremental backup (acts like "dump")
+ o Compression and buffering options for all backup types
+ o Does remote filesystems (over rsh/ssh; no special service)
+ o Package delta mode can backup files not owned by rpm, or owned+changed files.
+ o Writes to tapes, on-disk archive files, or on-disk directory trees
+ o Keeps a table of contents so you know what archives are on each tape
+ o Nice log files
+
+After installing, read the README for information on how to use.
diff --git a/system/flexbackup/doinst.sh b/system/flexbackup/doinst.sh
new file mode 100644
index 0000000000..e8837a3cde
--- /dev/null
+++ b/system/flexbackup/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/flexbackup.conf.new
diff --git a/system/flexbackup/flexbackup.SlackBuild b/system/flexbackup/flexbackup.SlackBuild
new file mode 100644
index 0000000000..8c1c65f7bf
--- /dev/null
+++ b/system/flexbackup/flexbackup.SlackBuild
@@ -0,0 +1,65 @@
+#!/bin/sh
+# Slackware build script for flexbackup
+#
+# Copyright 2013 klaatu at member.fsf.org
+#
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=flexbackup
+VERSION=${VERSION:-1.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# patch Makefile
+#sed -i "s%/usr%$PKG%" $TMP/$PRGNAM-$VERSION/Makefile
+#sed -i "s%/share/man%/man%" $TMP/$PRGNAM-$VERSION/Makefile
+#make install
+
+# mkdir $PKG/etc $PKG/usr/bin/ $PKG/usr/man/man{1,5}
+install -m 0644 flexbackup.conf -D $PKG/etc/flexbackup.conf.new
+install -m 0755 flexbackup -D $PKG/usr/bin/flexbackup
+install -m 0644 flexbackup.1 -D $PKG/usr/man/man1/flexbackup.1
+install -m 0644 flexbackup.conf.5 -D $PKG/usr/man/man5/flexbackup.5
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES COPYING CREDITS INSTALL \
+ README TODO faq.html $PRGNAM.spec \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/flexbackup/flexbackup.info b/system/flexbackup/flexbackup.info
new file mode 100644
index 0000000000..f0f479fb08
--- /dev/null
+++ b/system/flexbackup/flexbackup.info
@@ -0,0 +1,10 @@
+PRGNAM="flexbackup"
+VERSION="1.2.1"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+DOWNLOAD="http://flexbackup.sourceforge.net/tarball/flexbackup-1.2.1.tar.gz"
+MD5SUM="4955c89dbee354248f354a9bf0a480dd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.fsf.org"
diff --git a/system/flexbackup/slack-desc b/system/flexbackup/slack-desc
new file mode 100644
index 0000000000..579c1ebfcc
--- /dev/null
+++ b/system/flexbackup/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+flexbackup: flexbackup (a flexible backup tool)
+flexbackup:
+flexbackup: A perl script that uses dump, afio, GNU tar, cpio, star, pax, or
+flexbackup: zip archivers to make backing up easy.
+flexbackup:
+flexbackup: http://flexbackup.sourceforge.net/
+flexbackup:
+flexbackup:
+flexbackup:
+flexbackup:
+flexbackup: \ No newline at end of file