summaryrefslogtreecommitdiffstats
path: root/system/fxload/fxload.SlackBuild
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2010-05-13 00:40:23 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:40:23 +0200
commit456abf8065358fbb3900340d5488e97a23a62e1d (patch)
treeb8ad6964ada80dbd76bc9652a200d8252ab19539 /system/fxload/fxload.SlackBuild
parent662832272c41227748e4e408bbea1bf56f57a35c (diff)
downloadslackbuilds-456abf8065358fbb3900340d5488e97a23a62e1d.tar.gz
slackbuilds-456abf8065358fbb3900340d5488e97a23a62e1d.tar.xz
system/fxload: Updated for version 2008_10_13
Diffstat (limited to 'system/fxload/fxload.SlackBuild')
-rw-r--r--system/fxload/fxload.SlackBuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/system/fxload/fxload.SlackBuild b/system/fxload/fxload.SlackBuild
index 22a085a8d0..0a3db22479 100644
--- a/system/fxload/fxload.SlackBuild
+++ b/system/fxload/fxload.SlackBuild
@@ -2,9 +2,8 @@
# Slackware build script for fxload
-# Copyright 2009 Andre Barboza
-# All rights reserved.
-#
+# Written by Andre Barboza <bmg.andre at gmail.com>
+
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
@@ -22,7 +21,6 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Written by Andre Barboza <bmg.andre at gmail.com>
PRGNAM=fxload
VERSION=${VERSION:-2008_10_13}
@@ -37,10 +35,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -58,9 +59,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-patch Makefile $CWD/Makefile.patch
-
-CFLAGS="$SLKCFLAGS" make
+RPM_OPT_FLAGS="$SLKCFLAGS" make
make install prefix=$PKG
( cd $PKG
@@ -84,4 +83,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}