summaryrefslogtreecommitdiffstats
path: root/system/lirc/lirc.SlackBuild
diff options
context:
space:
mode:
author dsomero <xgizzmo@slackbuilds.org>2011-03-29 20:12:27 -0400
committer Robby Workman <rworkman@slackbuilds.org>2011-03-30 22:52:09 -0500
commit6f2665dc8c198df22e2c47b46e255f1d0b6c0546 (patch)
tree9f1ce5236b27ee139dc5db1611ab96ceb445ad17 /system/lirc/lirc.SlackBuild
parentdfa18a8d5719ba2518d31c63870f5841ed96f0ae (diff)
downloadslackbuilds-6f2665dc8c198df22e2c47b46e255f1d0b6c0546.tar.gz
slackbuilds-6f2665dc8c198df22e2c47b46e255f1d0b6c0546.tar.xz
system/lirc: Updated for version 0.9.0.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system/lirc/lirc.SlackBuild')
-rw-r--r--system/lirc/lirc.SlackBuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/system/lirc/lirc.SlackBuild b/system/lirc/lirc.SlackBuild
index b187fbc4ad..a572d5c39f 100644
--- a/system/lirc/lirc.SlackBuild
+++ b/system/lirc/lirc.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=lirc
-VERSION=${VERSION:-0.8.6}
+VERSION=${VERSION:-0.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,19 +74,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Disabling lirc_gpio driver as it does no longer work with kernel 2.6.22+
-sed -i -e "s:lirc_gpio\.o::" drivers/lirc_gpio/Makefile.am || exit 1
-
-# Fix building lirc_i2c - thanks to the Gentoo guys
-patch -p1 < $CWD/patches/lirc_i2c.patch
-
-# Fix building on 2.6.33.x kernels - thanks to the Gentoo guys
-patch -p1 < $CWD/patches/2.6.33.patch
-patch -p1 < $CWD/patches/autoconf.patch
-
-autoreconf
-libtoolize
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -120,10 +107,11 @@ cat contrib/lircmd.conf > $PKG/etc/lircmd.conf.new
cat contrib/lircrc > $PKG/etc/lircrc.new
cat $CWD/lirc.logrotate > $PKG/etc/logrotate.d/lirc.new
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ANNOUNCE AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \