summaryrefslogtreecommitdiffstats
path: root/system/qemu-kvm
diff options
context:
space:
mode:
author Stu Miller <slackbuilds@go4it2day.com>2011-05-10 22:23:47 -0500
committer Robby Workman <rworkman@slackbuilds.org>2011-05-10 22:23:47 -0500
commit65282ac79cd679e5b7321a0954640f873226e996 (patch)
tree43e71240f8de38576c228344cbdc86aa63e8f38d /system/qemu-kvm
parent49c0d6564bd00f6d99c462af1934728cf03807e1 (diff)
downloadslackbuilds-65282ac79cd679e5b7321a0954640f873226e996.tar.gz
slackbuilds-65282ac79cd679e5b7321a0954640f873226e996.tar.xz
system/qemu-kvm: Updated for version 0.14.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system/qemu-kvm')
-rw-r--r--system/qemu-kvm/fixup-undefined-pci-references.patch51
-rw-r--r--system/qemu-kvm/qemu-kvm.SlackBuild8
-rw-r--r--system/qemu-kvm/qemu-kvm.info8
3 files changed, 62 insertions, 5 deletions
diff --git a/system/qemu-kvm/fixup-undefined-pci-references.patch b/system/qemu-kvm/fixup-undefined-pci-references.patch
new file mode 100644
index 0000000000..4a002c7bf2
--- /dev/null
+++ b/system/qemu-kvm/fixup-undefined-pci-references.patch
@@ -0,0 +1,51 @@
+Replace obsolete qemu-kvm.h with kvm.h in pci.c and build that module
+just like upstream does. This fixes non-x86 targets which have no PCI
+support.
+
+Signed-off-by: Jan Kiszka <jan.kiszka@xxxxxxxxxxx>
+---
+ Makefile.objs | 2 +-
+ Makefile.target | 2 +-
+ hw/pci.c | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.objs b/Makefile.objs
+index f5702eb..3ec7121 100644
+--- a/Makefile.objs
++++ b/Makefile.objs
+@@ -170,7 +170,7 @@ hw-obj-y =
+ hw-obj-y += loader.o
+ hw-obj-$(CONFIG_VIRTIO) += virtio.o virtio-console.o
+ hw-obj-y += fw_cfg.o
+-hw-obj-$(CONFIG_PCI) += pci_bridge.o
++hw-obj-$(CONFIG_PCI) += pci.o pci_bridge.o
+ hw-obj-$(CONFIG_PCI) += msix.o msi.o
+ hw-obj-$(CONFIG_PCI) += pci_host.o pcie_host.o
+ hw-obj-$(CONFIG_PCI) += ioh3420.o xio3130_upstream.o xio3130_downstream.o
+diff --git a/Makefile.target b/Makefile.target
+index 6e9a024..23367eb 100644
+--- a/Makefile.target
++++ b/Makefile.target
+@@ -195,7 +195,7 @@ endif #CONFIG_BSD_USER
+ # System emulator target
+ ifdef CONFIG_SOFTMMU
+
+-obj-y = arch_init.o cpus.o monitor.o pci.o machine.o gdbstub.o vl.o balloon.o
++obj-y = arch_init.o cpus.o monitor.o machine.o gdbstub.o vl.o balloon.o
+ # virtio has to be here due to weird dependency between PCI and virtio-net.
+ # need to fix this properly
+ obj-$(CONFIG_NO_PCI) += pci-stub.o
+diff --git a/hw/pci.c b/hw/pci.c
+index 0c44939..1f6cebe 100644
+--- a/hw/pci.c
++++ b/hw/pci.c
+@@ -29,8 +29,8 @@
+ #include "net.h"
+ #include "sysemu.h"
+ #include "loader.h"
+-#include "qemu-kvm.h"
+ #include "hw/pc.h"
++#include "kvm.h"
+ #include "device-assignment.h"
+ #include "qemu-objects.h"
+ #include "range.h"
diff --git a/system/qemu-kvm/qemu-kvm.SlackBuild b/system/qemu-kvm/qemu-kvm.SlackBuild
index c67b6c6eaa..1c2768a1de 100644
--- a/system/qemu-kvm/qemu-kvm.SlackBuild
+++ b/system/qemu-kvm/qemu-kvm.SlackBuild
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=qemu-kvm
-VERSION=${VERSION:-0.13.0}
+VERSION=${VERSION:-0.14.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -88,12 +88,18 @@ find . \
# group to be used (no real need to require a kvm group)
patch -p1 < $CWD/fixup_udev_rules.patch
+# Replace obsolete qemu-kvm.h with kvm.h in pci.c and build that module
+# just like upstream does. This fixes non-x86 targets which have no PCI
+# support. http://www.mail-archive.com/kvm@vger.kernel.org/msg50038.html
+patch -p1 < $CWD/fixup-undefined-pci-references.patch
+
# This translates the possible targets into the correct format for configure
TARGETS="$(for i in $BUILD_ARCH ; do printf "$i-softmmu " ; done)"
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --sysconfdir=/etc \
--enable-mixemu \
--audio-drv-list=oss,alsa,sdl,esd \
--enable-system \
diff --git a/system/qemu-kvm/qemu-kvm.info b/system/qemu-kvm/qemu-kvm.info
index 10959e8333..2fdfb16d8f 100644
--- a/system/qemu-kvm/qemu-kvm.info
+++ b/system/qemu-kvm/qemu-kvm.info
@@ -1,10 +1,10 @@
PRGNAM="qemu-kvm"
-VERSION="0.13.0"
+VERSION="0.14.0"
HOMEPAGE="http://www.linux-kvm.org/page/Main_Page"
-DOWNLOAD="http://downloads.sourceforge.net/project/kvm/qemu-kvm/0.13.0/qemu-kvm-0.13.0.tar.gz"
-MD5SUM="68d100da381284a3dee486d3b9690e6d"
+DOWNLOAD="http://downloads.sourceforge.net/kvm/qemu-kvm-0.14.0.tar.gz"
+MD5SUM="4ea6f412d85a826e0b0690f5c4c59f13"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Stu Miller"
EMAIL="slackbuilds@go4it2day.com"
-APPROVED="dsomero"
+APPROVED="rworkman"