summaryrefslogtreecommitdiffstats
path: root/system/trash-cli/trash-cli.SlackBuild
diff options
context:
space:
mode:
author Donald Cooley <chytraeu@sdf.org>2017-01-25 11:05:17 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-01-28 07:38:04 +0700
commit1da64aa476ecdf76ad156541924069a57c9430a3 (patch)
tree6b93d5f44525cdd59bd53f8ccd290406139f37ea /system/trash-cli/trash-cli.SlackBuild
parent388723a7c0eb1e03b70bb7eec8e99496a1230522 (diff)
downloadslackbuilds-1da64aa476ecdf76ad156541924069a57c9430a3.tar.gz
slackbuilds-1da64aa476ecdf76ad156541924069a57c9430a3.tar.xz
system/trash-cli: Updated for version 0.17.1.14.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'system/trash-cli/trash-cli.SlackBuild')
-rw-r--r--system/trash-cli/trash-cli.SlackBuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/system/trash-cli/trash-cli.SlackBuild b/system/trash-cli/trash-cli.SlackBuild
index 8a3d03f900..a345343671 100644
--- a/system/trash-cli/trash-cli.SlackBuild
+++ b/system/trash-cli/trash-cli.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for the trash-cli utils.
#
# Copyright 2010 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
+# Copyright 2017 Donald Cooley South Haven, IN USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,16 +23,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Updated and reworked by Donald Cooley <dfc@warpmail.net>
PRGNAM=trash-cli
-VERSION=${VERSION:-0.12.9.14}
+VERSION=${VERSION:-0.17.1.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,8 +61,8 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -73,6 +73,9 @@ find -L . \
python setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir $PKG/usr/man
mv $PKG/usr/share/man/ $PKG/usr/
rmdir $PKG/usr/share
@@ -81,10 +84,11 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING CREDITS.txt DONE.txt HISTORY.txt MANIFEST.in README.rst TODO.txt bugs.txt requirements-dev.txt \
+cp -a \
+ COPYING CREDITS.txt DONE.txt HISTORY.txt README.rst TODO.txt \
+ bugs.txt requirements-dev.txt docs \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc