summaryrefslogtreecommitdiffstats
path: root/system/xen
diff options
context:
space:
mode:
author Mario Preksavec <mario@slackware.hr>2022-04-21 15:18:03 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-24 01:47:07 +0700
commit3002640d79134e422e7216d85368b7f105fff2b3 (patch)
tree5138b37d851e01bfe19f4b7ac4e6440c2c09582d /system/xen
parent6e793cfd5d97b142fa8de567e4a3124bb6c2d233 (diff)
downloadslackbuilds-3002640d79134e422e7216d85368b7f105fff2b3.tar.gz
slackbuilds-3002640d79134e422e7216d85368b7f105fff2b3.tar.xz
system/xen: Updated for version 4.16.1.
Signed-off-by: Mario Preksavec <mario@slackware.hr> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/xen')
-rw-r--r--system/xen/dom0/README.dom02
-rw-r--r--system/xen/dom0/kernel-xen.sh2
-rw-r--r--system/xen/patches/0001-BaseTools-fix-ucs-2-lookup-on-python-3.9.patch49
-rw-r--r--system/xen/patches/0002-BaseTools-Work-around-array.array.tostring-removal-i.patch51
-rw-r--r--system/xen/patches/0003-BaseTools-replace-deprecated-fromstring-and-tostring.diff60
-rw-r--r--system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff13
-rw-r--r--system/xen/xen.SlackBuild12
-rw-r--r--system/xen/xen.info10
8 files changed, 9 insertions, 190 deletions
diff --git a/system/xen/dom0/README.dom0 b/system/xen/dom0/README.dom0
index 96ecb2b036..327e2e00c7 100644
--- a/system/xen/dom0/README.dom0
+++ b/system/xen/dom0/README.dom0
@@ -57,7 +57,7 @@ kernel-xen.sh: This script builds the Linux Kernel for a Xen Hypervisor.
* To make things a bit easier, a copy of Xen EFI binary can be found here:
- http://slackware.hr/~mario/xen/xen-4.15.2.efi.gz
+ http://slackware.hr/~mario/xen/xen-4.16.1.efi.gz
!!! Make sure to understand what are you doing at this point, you could
easily lose your data. Always create backups !!!
diff --git a/system/xen/dom0/kernel-xen.sh b/system/xen/dom0/kernel-xen.sh
index 281a68893a..bee1bb42a2 100644
--- a/system/xen/dom0/kernel-xen.sh
+++ b/system/xen/dom0/kernel-xen.sh
@@ -6,7 +6,7 @@
# Modified by Mario Preksavec <mario@slackware.hr>
KERNEL=${KERNEL:-5.15.27}
-XEN=${XEN:-4.15.2}
+XEN=${XEN:-4.16.1}
ROOTMOD=${ROOTMOD:-ext4}
ROOTFS=${ROOTFS:-ext4}
diff --git a/system/xen/patches/0001-BaseTools-fix-ucs-2-lookup-on-python-3.9.patch b/system/xen/patches/0001-BaseTools-fix-ucs-2-lookup-on-python-3.9.patch
deleted file mode 100644
index f40f815cc4..0000000000
--- a/system/xen/patches/0001-BaseTools-fix-ucs-2-lookup-on-python-3.9.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From a32df3463befa04913fd1934ed264038a9eae00f Mon Sep 17 00:00:00 2001
-Message-Id: <a32df3463befa04913fd1934ed264038a9eae00f.1596577611.git.crobinso@redhat.com>
-From: Cole Robinson <crobinso@redhat.com>
-Date: Tue, 4 Aug 2020 17:04:50 -0400
-Subject: [PATCH 1/2] BaseTools: fix ucs-2 lookup on python 3.9
-
-python3.9 changed/fixed codec.register behavior to always replace
-hyphen with underscore for passed in codec names:
-
- https://bugs.python.org/issue37751
-
-So the custom Ucs2Search needs to be adapted to handle 'ucs_2' in
-addition to existing 'ucs-2' for back compat.
-
-This fixes test failures on python3.9, example:
-
-======================================================================
-FAIL: testUtf16InUniFile (CheckUnicodeSourceFiles.Tests)
-----------------------------------------------------------------------
-Traceback (most recent call last):
- File "/builddir/build/BUILD/edk2-edk2-stable202002/BaseTools/Source/Python/AutoGen/UniClassObject.py", line 375, in PreProcess
- FileIn = UniFileClassObject.OpenUniFile(LongFilePath(File.Path))
- File "/builddir/build/BUILD/edk2-edk2-stable202002/BaseTools/Source/Python/AutoGen/UniClassObject.py", line 303, in OpenUniFile
- UniFileClassObject.VerifyUcs2Data(FileIn, FileName, Encoding)
- File "/builddir/build/BUILD/edk2-edk2-stable202002/BaseTools/Source/Python/AutoGen/UniClassObject.py", line 312, in VerifyUcs2Data
- Ucs2Info = codecs.lookup('ucs-2')
-LookupError: unknown encoding: ucs-2
-
-Signed-off-by: Cole Robinson <crobinso@redhat.com>
----
- BaseTools/Source/Python/AutoGen/UniClassObject.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/BaseTools/Source/Python/AutoGen/UniClassObject.py b/BaseTools/Source/Python/AutoGen/UniClassObject.py
-index b2895f7e5c..883c2356e0 100644
---- a/BaseTools/Source/Python/AutoGen/UniClassObject.py
-+++ b/BaseTools/Source/Python/AutoGen/UniClassObject.py
-@@ -152,7 +152,7 @@ class Ucs2Codec(codecs.Codec):
-
- TheUcs2Codec = Ucs2Codec()
- def Ucs2Search(name):
-- if name == 'ucs-2':
-+ if name in ['ucs-2', 'ucs_2']:
- return codecs.CodecInfo(
- name=name,
- encode=TheUcs2Codec.encode,
---
-2.26.2
-
diff --git a/system/xen/patches/0002-BaseTools-Work-around-array.array.tostring-removal-i.patch b/system/xen/patches/0002-BaseTools-Work-around-array.array.tostring-removal-i.patch
deleted file mode 100644
index 3f569eaf11..0000000000
--- a/system/xen/patches/0002-BaseTools-Work-around-array.array.tostring-removal-i.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From f6e649b25150c1417ebcd595004da6d788d7c9c5 Mon Sep 17 00:00:00 2001
-Message-Id: <f6e649b25150c1417ebcd595004da6d788d7c9c5.1596577611.git.crobinso@redhat.com>
-In-Reply-To: <a32df3463befa04913fd1934ed264038a9eae00f.1596577611.git.crobinso@redhat.com>
-References: <a32df3463befa04913fd1934ed264038a9eae00f.1596577611.git.crobinso@redhat.com>
-From: Cole Robinson <crobinso@redhat.com>
-Date: Tue, 4 Aug 2020 17:24:32 -0400
-Subject: [PATCH 2/2] BaseTools: Work around array.array.tostring() removal in
- python 3.9
-
-In python3, array.array.tostring() was a compat alias for tobytes().
-tostring() was removed in python 3.9.
-
-Convert this to use tolist() which should be valid for all python
-versions.
-
-This fixes this build error on python3.9:
-
-(Python 3.9.0b5 on linux) Traceback (most recent call last):
- File "/root/edk2/edk2-edk2-stable202002/BaseTools/BinWrappers/PosixLike/../../Source/Python/Trim/Trim.py", line 593, in Main
- GenerateVfrBinSec(CommandOptions.ModuleName, CommandOptions.DebugDir, CommandOptions.OutputFile)
- File "/root/edk2/edk2-edk2-stable202002/BaseTools/BinWrappers/PosixLike/../../Source/Python/Trim/Trim.py", line 449, in GenerateVfrBinSec
- VfrUniOffsetList = GetVariableOffset(MapFileName, EfiFileName, VfrNameList)
- File "/root/edk2/edk2-edk2-stable202002/BaseTools/Source/Python/Common/Misc.py", line 88, in GetVariableOffset
- return _parseForGCC(lines, efifilepath, varnames)
- File "/root/edk2/edk2-edk2-stable202002/BaseTools/Source/Python/Common/Misc.py", line 151, in _parseForGCC
- efisecs = PeImageClass(efifilepath).SectionHeaderList
- File "/root/edk2/edk2-edk2-stable202002/BaseTools/Source/Python/Common/Misc.py", line 1638, in __init__
- if ByteArray.tostring() != b'PE\0\0':
-AttributeError: 'array.array' object has no attribute 'tostring'
-
-Signed-off-by: Cole Robinson <crobinso@redhat.com>
----
- BaseTools/Source/Python/Common/Misc.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/BaseTools/Source/Python/Common/Misc.py b/BaseTools/Source/Python/Common/Misc.py
-index da5fb380f0..751b2c24f0 100755
---- a/BaseTools/Source/Python/Common/Misc.py
-+++ b/BaseTools/Source/Python/Common/Misc.py
-@@ -1635,7 +1635,7 @@ class PeImageClass():
- ByteArray = array.array('B')
- ByteArray.fromfile(PeObject, 4)
- # PE signature should be 'PE\0\0'
-- if ByteArray.tostring() != b'PE\0\0':
-+ if ByteArray.tolist() != [ord('P'), ord('E'), 0, 0]:
- self.ErrorInfo = self.FileName + ' has no valid PE signature PE00'
- return
-
---
-2.26.2
-
diff --git a/system/xen/patches/0003-BaseTools-replace-deprecated-fromstring-and-tostring.diff b/system/xen/patches/0003-BaseTools-replace-deprecated-fromstring-and-tostring.diff
deleted file mode 100644
index 4c9f2b6674..0000000000
--- a/system/xen/patches/0003-BaseTools-replace-deprecated-fromstring-and-tostring.diff
+++ /dev/null
@@ -1,60 +0,0 @@
---- xen-ovmf-20190606_20d2e5a125/BaseTools/Source/Python/Eot/EotMain.py.orig 2019-06-06 06:51:42.000000000 +0200
-+++ xen-ovmf-20190606_20d2e5a125/BaseTools/Source/Python/Eot/EotMain.py 2020-12-25 20:10:44.332843625 +0100
-@@ -152,11 +152,11 @@
- try:
- TmpData = DeCompress('Efi', self[self._HEADER_SIZE_:])
- DecData = array('B')
-- DecData.fromstring(TmpData)
-+ list(map(lambda str: DecData.fromlist([ord(str), 0]), TmpData))
- except:
- TmpData = DeCompress('Framework', self[self._HEADER_SIZE_:])
- DecData = array('B')
-- DecData.fromstring(TmpData)
-+ list(map(lambda str: DecData.fromlist([ord(str), 0]), TmpData))
-
- SectionList = []
- Offset = 0
-@@ -196,7 +196,7 @@
- return len(self)
-
- def _GetUiString(self):
-- return codecs.utf_16_decode(self[0:-2].tostring())[0]
-+ return codecs.utf_16_decode(self[0:-2].tobytes())[0]
-
- String = property(_GetUiString)
-
-@@ -738,7 +738,7 @@
- Offset = self.DataOffset - 4
- TmpData = DeCompress('Framework', self[self.Offset:])
- DecData = array('B')
-- DecData.fromstring(TmpData)
-+ list(map(lambda str: DecData.fromlist([ord(str), 0]), TmpData))
- Offset = 0
- while Offset < len(DecData):
- Sec = Section()
-@@ -759,7 +759,7 @@
-
- TmpData = DeCompress('Lzma', self[self.Offset:])
- DecData = array('B')
-- DecData.fromstring(TmpData)
-+ list(map(lambda str: DecData.fromlist([ord(str), 0]), TmpData))
- Offset = 0
- while Offset < len(DecData):
- Sec = Section()
---- xen-ovmf-20190606_20d2e5a125/BaseTools/Source/Python/GenFds/GenFdsGlobalVariable.py.orig 2019-06-06 06:51:42.000000000 +0200
-+++ xen-ovmf-20190606_20d2e5a125/BaseTools/Source/Python/GenFds/GenFdsGlobalVariable.py 2020-12-25 20:10:39.188843812 +0100
-@@ -469,12 +469,12 @@
- GenFdsGlobalVariable.SecCmdList.append(' '.join(Cmd).strip())
- else:
- SectionData = array('B', [0, 0, 0, 0])
-- SectionData.fromstring(Ui.encode("utf_16_le"))
-+ list(map(lambda str: SectionData.fromlist([ord(str), 0]), Ui))
- SectionData.append(0)
- SectionData.append(0)
- Len = len(SectionData)
- GenFdsGlobalVariable.SectionHeader.pack_into(SectionData, 0, Len & 0xff, (Len >> 8) & 0xff, (Len >> 16) & 0xff, 0x15)
-- SaveFileOnChange(Output, SectionData.tostring())
-+ SaveFileOnChange(Output, SectionData.tobytes())
-
- elif Ver:
- Cmd += ("-n", Ver)
diff --git a/system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff b/system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff
deleted file mode 100644
index b7fab4dd6e..0000000000
--- a/system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tools/firmware/etherboot/Makefile b/tools/firmware/etherboot/Makefile
-index ed9e11305f..4bc3633ba3 100644
---- a/tools/firmware/etherboot/Makefile
-+++ b/tools/firmware/etherboot/Makefile
-@@ -10,7 +10,8 @@ else
- IPXE_GIT_URL ?= git://git.ipxe.org/ipxe.git
- endif
-
--IPXE_GIT_TAG := 988d2c13cdf0f0b4140685af35ced70ac5b3283c
-+# put an updated tar.gz on xenbits after changes to this variable
-+IPXE_GIT_TAG := 3c040ad387099483102708bb1839110bc788cefb
-
- IPXE_TARBALL_URL ?= $(XEN_EXTFILES_URL)/ipxe-git-$(IPXE_GIT_TAG).tar.gz
diff --git a/system/xen/xen.SlackBuild b/system/xen/xen.SlackBuild
index cfc3ad8f00..3b0a9fded0 100644
--- a/system/xen/xen.SlackBuild
+++ b/system/xen/xen.SlackBuild
@@ -25,13 +25,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xen
-VERSION=${VERSION:-4.15.2}
+VERSION=${VERSION:-4.16.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
SEABIOS=${SEABIOS:-1.14.0}
-OVMF=${OVMF:-20200807_a3741780fe}
+OVMF=${OVMF:-20210824_7b4a99be8a}
IPXE=${IPXE:-3c040ad387099483102708bb1839110bc788cefb}
if [ -z "$ARCH" ]; then
@@ -42,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -177,9 +174,6 @@ fi
# Fix ovmf firmware build
( cd tools/firmware/ovmf-dir-remote && \
- patch -p1 <$CWD/patches/0001-BaseTools-fix-ucs-2-lookup-on-python-3.9.patch
- patch -p1 <$CWD/patches/0002-BaseTools-Work-around-array.array.tostring-removal-i.patch
- patch -p1 <$CWD/patches/0003-BaseTools-replace-deprecated-fromstring-and-tostring.diff
patch -p1 <$CWD/patches/edk2-ovmf-202105-werror.patch
)
@@ -188,8 +182,6 @@ if [ "$(objcopy --version | awk '{print $NF; exit}' | cut -d- -f1)" = "2.36" ];
patch -p1 <$CWD/patches/qemu-xen-no-pie.diff
fi
-patch -p1 <$CWD/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/system/xen/xen.info b/system/xen/xen.info
index c6a605a210..e6c8cb4da0 100644
--- a/system/xen/xen.info
+++ b/system/xen/xen.info
@@ -1,9 +1,9 @@
PRGNAM="xen"
-VERSION="4.15.2"
+VERSION="4.16.1"
HOMEPAGE="http://www.xenproject.org/"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
-DOWNLOAD_x86_64="http://mirror.slackware.hr/sources/xen/xen-4.15.2.tar.gz \
+DOWNLOAD_x86_64="http://mirror.slackware.hr/sources/xen/xen-4.16.1.tar.gz \
http://mirror.slackware.hr/sources/xen-extfiles/ipxe-git-3c040ad387099483102708bb1839110bc788cefb.tar.gz \
http://mirror.slackware.hr/sources/xen-extfiles/lwip-1.3.0.tar.gz \
http://mirror.slackware.hr/sources/xen-extfiles/zlib-1.2.3.tar.gz \
@@ -14,8 +14,8 @@ DOWNLOAD_x86_64="http://mirror.slackware.hr/sources/xen/xen-4.15.2.tar.gz \
http://mirror.slackware.hr/sources/xen-extfiles/gmp-4.3.2.tar.bz2 \
http://mirror.slackware.hr/sources/xen-extfiles/tpm_emulator-0.7.4.tar.gz \
http://mirror.slackware.hr/sources/xen-seabios/seabios-1.14.0.tar.gz \
- http://mirror.slackware.hr/sources/xen-ovmf/xen-ovmf-20200807_a3741780fe.tar.bz2"
-MD5SUM_x86_64="d85ce5d677c7713b6b91017d3aa8b68c \
+ http://mirror.slackware.hr/sources/xen-ovmf/xen-ovmf-20210824_7b4a99be8a.tar.bz2"
+MD5SUM_x86_64="1c2cd4f7f966c1d455aab630953e5fad \
23ba00d5e2c5b4343d12665af73e1cb5 \
36cc57650cffda9a0269493be2a169bb \
debc62758716a169df9f62e6ab2bc634 \
@@ -26,7 +26,7 @@ MD5SUM_x86_64="d85ce5d677c7713b6b91017d3aa8b68c \
dd60683d7057917e34630b4a787932e8 \
e26becb8a6a2b6695f6b3e8097593db8 \
9df3b7de6376850d09161137e7a9b61f \
- b5a9f9870e147106cd917afba83011e2"
+ 322d42a3378394b5486acc1564651a4f"
REQUIRES="acpica yajl"
MAINTAINER="Mario Preksavec"
EMAIL="mario at slackware dot hr"