summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2015-12-31 16:36:34 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-17 09:40:16 +0700
commit1f0c29957fa8a0619453e92b8e87deb8960db789 (patch)
tree71a5c6e5d08950da5560ca9dc259ed02fc4ca90f /system
parent304cc19021bc1e2fa58b89e2185b8c7b14a8802f (diff)
downloadslackbuilds-1f0c29957fa8a0619453e92b8e87deb8960db789.tar.gz
slackbuilds-1f0c29957fa8a0619453e92b8e87deb8960db789.tar.xz
system/tc-play: Fixed build failure on -current.
Don't use hardcoded -fPIE. Signed-off-by: David Spencer <baildon.research@googlemail.com>
Diffstat (limited to 'system')
-rw-r--r--system/tc-play/tc-play.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/system/tc-play/tc-play.SlackBuild b/system/tc-play/tc-play.SlackBuild
index 43df6d0763..8fc01bb169 100644
--- a/system/tc-play/tc-play.SlackBuild
+++ b/system/tc-play/tc-play.SlackBuild
@@ -1,4 +1,3 @@
-
#!/bin/sh
# Slackware build script for tc-play
@@ -71,10 +70,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Don't force these flags kthxbye
+sed -i \
+ -e "s/-O3//" \
+ -e "s/-fPIE//" \
+ CMakeLists.txt
+
mkdir -p build
cd build
cmake \
- DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
@@ -92,6 +97,7 @@ rm -f $PKG/usr/lib${LIBDIRSUFFIX}/libtcplay.a
mkdir -p $PKG/usr/man
mv $PKG/usr/share/man/* $PKG/usr/man
rm -r $PKG/usr/share
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done