summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/Nevow/Nevow.SlackBuild107
-rw-r--r--libraries/Nevow/Nevow.info10
-rw-r--r--libraries/Nevow/README14
-rw-r--r--libraries/Nevow/slack-desc19
4 files changed, 0 insertions, 150 deletions
diff --git a/libraries/Nevow/Nevow.SlackBuild b/libraries/Nevow/Nevow.SlackBuild
deleted file mode 100644
index 77883080ab..0000000000
--- a/libraries/Nevow/Nevow.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Nevow
-
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2014-2018 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Originally written by Marco Bonetti - Thanks!
-# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Nevow
-VERSION=${VERSION:-0.14.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/man/man1 $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/doc/man/* $PKG/usr/man/man1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-rm -rf $PKG/usr/doc/man
-
-mkdir $PKG/usr/DOCS ; mv $PKG/usr/doc/* $PKG/usr/DOCS
-mv $PKG/usr/DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE ChangeLog *.rst $PKG/usr/doc/$PRGNAM-$VERSION
-rm -frd $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-$VERSION $PKG/usr/doc/$PRGNAM-$VERSION/_*
-
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/Nevow/Nevow.info b/libraries/Nevow/Nevow.info
deleted file mode 100644
index da3994f9e7..0000000000
--- a/libraries/Nevow/Nevow.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Nevow"
-VERSION="0.14.4"
-HOMEPAGE="https://pypi.python.org/pypi/Nevow"
-DOWNLOAD="https://files.pythonhosted.org/packages/d6/24/fdfae1b49587d51e4cd4cd5b8c171682fbc67d8e9c7e54581be107ae3925/Nevow-0.14.4.tar.gz"
-MD5SUM="b66b8c5ff7b8a05a77c91d30736550f8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-twisted"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
diff --git a/libraries/Nevow/README b/libraries/Nevow/README
deleted file mode 100644
index 0c77ccf7c8..0000000000
--- a/libraries/Nevow/README
+++ /dev/null
@@ -1,14 +0,0 @@
-Pronounced as the French "nouveau", or "noo-voh", Nevow is a web
-application construction kit written in Python. It is designed to
-allow the programmer to express as much of the view logic as desired
-in Python, and includes a pure Python XML expression syntax named
-stan to facilitate this. However it also provides rich support for
-designer-edited templates, using a very small XML attribute language
-to provide bi-directional template manipulation capability.
-
-Nevow also includes formless, a declarative syntax for specifying
-the types of method parameters and exposing these methods to
-the web. Forms can be rendered automatically, and form posts
-will be validated and input coerced, rendering error pages if
-appropriate. Once a form post has validated successfully, the method
-will be called with the coerced values.
diff --git a/libraries/Nevow/slack-desc b/libraries/Nevow/slack-desc
deleted file mode 100644
index bd95ff95f9..0000000000
--- a/libraries/Nevow/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Nevow: Nevow (web application construction kit)
-Nevow:
-Nevow: Nevow is designed to allow the programmer to express as much of the
-Nevow: view logic as desired in Python, and includes a pure Python XML
-Nevow: expression syntax named stan to facilitate this. However it also
-Nevow: provides rich support for designer-edited templates, using a very
-Nevow: small XML attribute language to provide bi-directional template
-Nevow: manipulation capability.
-Nevow:
-Nevow: https://pypi.python.org/pypi/Nevow
-Nevow: