summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python-tblib/README5
-rw-r--r--python/python-tblib/slack-desc19
-rw-r--r--python/python2-tblib/README5
-rw-r--r--python/python2-tblib/python2-tblib.SlackBuild (renamed from python/python-tblib/python-tblib.SlackBuild)11
-rw-r--r--python/python2-tblib/python2-tblib.info (renamed from python/python-tblib/python-tblib.info)2
-rw-r--r--python/python2-tblib/slack-desc19
6 files changed, 31 insertions, 30 deletions
diff --git a/python/python-tblib/README b/python/python-tblib/README
deleted file mode 100644
index ae5cc5abf4..0000000000
--- a/python/python-tblib/README
+++ /dev/null
@@ -1,5 +0,0 @@
-A traceback serialization library that allows you to pickle tracebacks and
-raise exceptions with pickled tracebacks in different processes. This allows
-better error handling when running code over multiple processes (imagine
-multiprocessing, billiard, futures, celery etc). It also parses traceback
-strings and raise with the parsed tracebacks.
diff --git a/python/python-tblib/slack-desc b/python/python-tblib/slack-desc
deleted file mode 100644
index e5201435a5..0000000000
--- a/python/python-tblib/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-tblib: python-tblib (Traceback serialization library)
-python-tblib:
-python-tblib: A traceback serialization library that allows you to pickle tracebacks
-python-tblib: and raise exceptions with pickled tracebacks in different processes.
-python-tblib: This allows better error handling when running code over multiple
-python-tblib: processes (imagine multiprocessing, billiard, futures, celery etc).
-python-tblib: It also parses traceback strings and raise with the parsed tracebacks.
-python-tblib:
-python-tblib: Home page: https://github.com/ionelmc/python-tblib
-python-tblib:
-python-tblib:
diff --git a/python/python2-tblib/README b/python/python2-tblib/README
new file mode 100644
index 0000000000..dc347e28bf
--- /dev/null
+++ b/python/python2-tblib/README
@@ -0,0 +1,5 @@
+A traceback serialization library that allows you to pickle tracebacks
+and raise exceptions with pickled tracebacks in different processes.
+This allows better error handling when running code over multiple
+processes (imagine multiprocessing, billiard, futures, celery etc). It
+also parses traceback strings and raise with the parsed tracebacks.
diff --git a/python/python-tblib/python-tblib.SlackBuild b/python/python2-tblib/python2-tblib.SlackBuild
index 28230a36c2..739979a0bd 100644
--- a/python/python-tblib/python-tblib.SlackBuild
+++ b/python/python2-tblib/python2-tblib.SlackBuild
@@ -22,7 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-tblib
+PRGNAM=python2-tblib
+SRCNAM=python-tblib
VERSION=${VERSION:-1.3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +60,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-tblib/python-tblib.info b/python/python2-tblib/python2-tblib.info
index b8575175ac..af32c756dd 100644
--- a/python/python-tblib/python-tblib.info
+++ b/python/python2-tblib/python2-tblib.info
@@ -1,4 +1,4 @@
-PRGNAM="python-tblib"
+PRGNAM="python2-tblib"
VERSION="1.3.2"
HOMEPAGE="https://github.com/ionelmc/python-tblib"
DOWNLOAD="https://github.com/ionelmc/python-tblib/archive/v1.3.2/python-tblib-1.3.2.tar.gz"
diff --git a/python/python2-tblib/slack-desc b/python/python2-tblib/slack-desc
new file mode 100644
index 0000000000..901fe19240
--- /dev/null
+++ b/python/python2-tblib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-tblib: python2-tblib (Traceback serialization library)
+python2-tblib:
+python2-tblib: A traceback serialization library that allows you to pickle tracebacks
+python2-tblib: and raise exceptions with pickled tracebacks in different processes.
+python2-tblib: This allows better error handling when running code over multiple
+python2-tblib: processes (imagine multiprocessing, billiard, futures, celery etc).
+python2-tblib: It also parses traceback strings and raise with the parsed tracebacks.
+python2-tblib:
+python2-tblib: Home page: https://github.com/ionelmc/python2-tblib
+python2-tblib:
+python2-tblib: